1 2 Previous Next 20 Replies Latest reply on Feb 7, 2014 4:47 AM by john.s

    Security Access Help

    john.s

      Title

      Security Access Help

      Post

           Hi,

           I have a layout with a portal and a button to delete the portal row.  It works when i am logged in as Admin but not when logged in as other users.

           The layout is based on Jobs table and the Portal is to Join_Customer_Jobs

           I have the following security access for each table

                                                             View    Edit    Create    Delete    Fields

           Jobs                                          yes       yes      yes        limited      all

           Join_Customer_Jobs             yes      yes      yes          yes         all

           The delete limitationon the Jobs table is to allow only the deletion of records if the New Record Flag is set.  I can't figure out why it will not allow the deletion of portal rows on Join_Customer_Jobs.  There is no limitation on delete for that table.

           Any help will be appreciated.

            

        • 1. Re: Security Access Help
          john.s

               OK this might not be a security access issue.  It just failed for me while I was logged in as admin.  I've tried it a few times…sometimes it works and sometimes it doesn't.  I have not been able to isolate any condition that triggers the failure.  I tried to look this up in the link to known bugs DB that PhilModJunk sent but I very quickly got lost.

               I can use all the help I can get is resolving this.

               Thanks

          • 2. Re: Security Access Help
            philmodjunk

                 What options did you select for your button in order for it to delete the portal row. Did you create a script or just select the "delete portal row" button option?

            • 3. Re: Security Access Help
              john.s

                   Just selected "delete portal row"

              • 4. Re: Security Access Help
                philmodjunk

                     There have been some pretty infrequent reports of issues with being unable to delete a portal row though I have never personally had any trouble with it.

                     For More Information see:     Delete portal row issue

                     This is one of many acknowledged bugs that can be found in the Known Bug List thread here in the Report an Issue section of the forum.

                     It can also be downloaded as a database file from:    https://www.dropbox.com/s/jt09b82i0xijbu3/FMP%20Bugs.zip

                • 5. Re: Security Access Help
                  john.s

                       Thanks Phil,

                       From reading the posts it looks like this has been an issue that has stumped the experts for a few years.  I just noticed a pattern that I have repeated several times.  So far this failure to delete happens the first time after logging in…if I go back and try again it works.  I don't know if it will work every time but it does not work the first time.  I'm hoping if I create a script that on Layout open creates a dummy job deletes a portal row and then deletes the job it might trick the system into thinking this is not the first attempt.  Just guessing at this point.

                        

                  • 6. Re: Security Access Help
                    philmodjunk

                         Before doing anything like that, I suggest very carefully ruling out other possible causes. That includes trying this on a recovered copy of your file (even if recover reports no problems found) and if that fails, a brand new created from scratch copy of your layout. (You can create a blank layout with just the portal to test and if the new layout works, you can then do the needed work to replace your original layout with the new layout.)

                    • 7. Re: Security Access Help
                      john.s

                           Great advise…I'll try this first…I was just thinking that if I do have to go the script route that I was considering I would want to do it on login not on layout enter.  Hopefully I'll get it resolved with your suggestions.

                      • 8. Re: Security Access Help
                        john.s

                             OK,  I've narrowed the problem down even further.  I created a new layout and have the same problem.  Using a restored version…same problem.  So I downloaded a copy of the DB from the server…we're using a hosting company (currently in a trial period) so we can share the data base without having to invest in a lot of server equipment...and ran it locally on my desktop.  The portal delete button works as planned.  So it seems the problem is somewhere in the FM Server software.  I just don't know how to work around the problem.

                        • 9. Re: Security Access Help
                          philmodjunk

                               Create and host a completely new file. Don't invest a lot of time in this, just create enough features to get a portal with your delete button and see if it exhibits the same behavior.

                          • 10. Re: Security Access Help
                            john.s

                                 I just created a new file from scratch…no frills just the necessary tables and a few fields.  The problem persists…the first time I use the button to delete the row it fails…add new record and it works as planned.  As before the file works ok if I run it locally but not when on the server.

                                  

                            • 11. Re: Security Access Help
                              philmodjunk

                                   the first time I use the button to delete the row it fails…add new record and it works as planned.

                                   Hmmm, is "allow creation of records via this relationship" enabled? Could you be trying to delete a portal record that does not exist?

                                   With "allow creation" enabled, there is what looks like a new blank record that automatically appears in the portal. But this is not actually a portal record and cannot be deleted. It's the bottom "add" row used to add new related records to the portal.

                              • 12. Re: Security Access Help
                                john.s

                                     I do have the "allow creation" enabled.  I opened the Join table and can see the records being created.  For example I just selected three schools and three records were created in the join table and one in the Jobs table.  I can change the school in any portal record but I can not delete any of the portal rows using the button.  I then do add new record and a second job records is created I select a couple of schools and those records are created in the join table and I can delete them or change them.  When I do this in the original database I have a button to delete the entire Job record (which also deletes the join records) and even doing that allows the delete portal row button to work on the next record created.

                                     It only happens on the first record created after logging in.  WEIRD

                                • 13. Re: Security Access Help
                                  philmodjunk

                                       Is this portal, a portal to the join table?

                                  • 14. Re: Security Access Help
                                    john.s

                                         Yes

                                          

                                    1 2 Previous Next