4 Replies Latest reply on Apr 27, 2012 10:54 AM by GMack

    Security, locking a record



      Security, locking a record


      In Filemaker 11.0v3 I created a field named "Lock" that is a check box.

      I created a custom privilege set that included a limited edit statement of If "(IsEmpty(Lock) or Get(ActiveFieldName) = "Lock" ; 1 ; 0 )"

      When the box is checked the users cannot edit anything in the affected record, when unchecked they have their typical access.

      The issue that has arisen is that even though the box is unchecked, my users are unable to copy and paste into any field.

      Is this a negative side effect or...What the heck did I do wrong?!


        • 1. Re: Security, locking a record

          If "(IsEmpty(Lock) or Get(ActiveFieldName) = "Lock" ; 1 ; 0 )"

          You don't actually have the quotes I've shown in read do you? They shouldn't be there, but I'd expect you to get an error message if that's how you entered your actual lock expression.

          • 2. Re: Security, locking a record

            No I do not have Lock in quotes, i copied that from a reference file I keep.

            The actual from the privilege set is:If (IsEmpty(Lock) or Get(ActiveFieldName) = "Lock" ; 1 ; 0 )

            In addition to not being able to cut and paste, the Filemaker  menu bar containing "New Record, Delete Record etc" is grayed out and unaccessable?

            • 3. Re: Security, locking a record


              Go to manage | security and edit the privilege set. There's a drop down in the lower right corner that controls what menu options are available. Select a less restrictive option that includes more menu options in your menus and this will likely work.

              PS. Your lock expression can be simplified to be:

              IsEmpty(Lock) or Get(ActiveFieldName) = "Lock"

              Contrary to what you might think from the example in FileMaker help, the if function is not needed in your expression.

              • 4. Re: Security, locking a record

                 Thank you once again Phil, the drop down solved my problem and the new lock expression is much cleaner.