3 Replies Latest reply on Sep 11, 2012 8:57 AM by TurtleKoala

    Selecting current record not working

    TurtleKoala

      Title

      Selecting current record not working

      Post

           I have a script (which I am attaching a screenshot of) which finds employee feedback for an employee whose name is entered by the user. The name is entered into Global::gFirst and Global::gLast. First, the script performs a find based on these entries. It then checks if more than one record was found. If it was, it goes to the Select Employee layout and pauses the script. The Select Employee layout is a list where each line contains the employee's First and Last name and a button to select that employee. The button is set to resume current script as well as perform a script to select the current record. That script is simply

           Show All Records

           Omit Record

           Show Omitted Only

           The script then continues as can be seen in the screenshot.

           When I run this script, after I press the button to select an employee, I stay on the Select Employee layout, and 49 seemingly random records are displayed. The records do not seem to have anything in common with each other, and it always appears to be the same 49 records, no matter what my original inputs are.

            

           If I go directly to the Select Employee layout, the buttons correctly select an employee. Also, I have used this method in another script, and it has worked correctly there as well.

           My only thought is that the script to get the current record may be running at the same time as the original script which has been resumed, and this may be causing a conflict. However, if this is happening, I don't know the best way to fix it.