2 Replies Latest reply on Jun 12, 2012 10:41 AM by philmee95

    Send Event Copy, File "copy" not found, but xcopy works in WIN

    philmee95

      Title

      Send Event Copy, File "copy" not found, but xcopy works in WIN

      Post

      We are still having random server 11 hangs (remedied for awhile when fmp 12 was removed from the 4 peoples computers that use this program in FMP 11, but now additional people that have to use 12, and help with 11 started some lockups again) so we are going to move a db to 12 finally. My work around involves copying and renaming files so fielmaker 12 can import them. I have to send events to windows in a script step to copy files and put a new file suffix on them so that they can be imported as db4 files.

      1 step is xcopy to get a list of all unique header files and rename them as dbf files. Unfortunately xcopy seems to have it's own bug or limitation that won't let me slap on an additional extension to the file. Each unique file batches has 8 to 15 files with the same base file name and different file extension. Each file is a db4 file.

      when I run the Send Event xcopy all is well. When I run send event "copy source dest /y" filemaker comes back with can't find file "copy". I run the command line scripts in dos no problem. All machines will be FMP on windows.

      works fine:

      xcopy "p:\ems-out\*.env" "C:\Users\me\Desktop\Bodyshop\ems-test\fmp-xcopy\*.dbf"  /y /d

      file copy not found:

      copy.exe "p:\ems-out\0a135636.*" "C:\Users\me\Desktop\Bodyshop\ems-test\fmp-xcopy\*.*.dbf"  /y

      0a135636 is the unique file base name. *.*.dbf copies all of the files with that base file name and slaps on a dbf extension.

      Sorry if this has baeen answered already, but the forum search returned amost all posts on "send event copy"

      FMP_Send_Event_Copy_Error.jpg