AnsweredAssumed Answered

Set Field Not Pulling Data?

Question asked by RodrigoPerez on Jun 14, 2012
Latest reply on Jun 14, 2012 by philmodjunk

Title

Set Field Not Pulling Data?

Post

Help, please!

I'm probably missing something very fundamental, but have gotten stuck while creating a simple project tracking database.  Any insight as to what I'm doing wrong will be greatly appreciated!

My database has two tables: a Projects Table and a Tasks Table.  The Projects Table contains a field called Project ID Number, which contains an auto-generated serial number to identify each unique project.  The Tasks Table also has a field named Project ID Number, which I'm trying to populate with the serial number from the Projects Table at creation of the Task.  This will then tie the Task to that particular Project.

In the Project Table's layout, I have added a button that when clicked runs a script to make a new Task.  It looks like this:

Go to Layout ["Task Table" (Task Table)]

New Record/Request

Set Field [Task Table::Project ID Number; Project Table::Project ID Number]

Go to Layout [original layout]

When I run the script, I get a new Task Table record, but the Task Table field, Project ID Number, is blank.

If I change the Set Field command to Set Field [Task Table::Project ID Number; 99] and run the script it works just fine and places 99 in the Project ID Number field.

I have set up a relationship between the two Project ID Number fields in both tables, but still get nothing when running the Set Field command.  Here's hoping that this post makes sense to someone!

Ideas, anyone?

Outcomes