AnsweredAssumed Answered

Set Variable Not performing as Expected

Question asked by quirkycrone on Mar 27, 2014
Latest reply on Mar 29, 2014 by RickWhitelaw

Title

Set Variable Not performing as Expected

Post

     I have a field called Collection_OOAK  in a table called Prints. I attached a value list that shows all the separate instanced of OOAK_Collection to enable selection.  Then (I have tried running this script as OnVerify and OnSave with equally dismal results) I run this script (see screenshot).  When I test it it fails to put anything into the variable $$Collection--so of course it fails to find any matching records

     Any thoughts on why $$Collection ends up empty?  I am using FM 12 on a PC.  The only possible problem that I imagine is that while the field Collection_OOAK is a text field, the data is numeric formatted like ####-##.

     I have been searching and searching for problems with set variable not working properly...but have not yet found a solution for this.

     Thanks in advance.

     Nel

      

Prob_w_Collection.PNG

Outcomes