6 Replies Latest reply on Jul 23, 2012 10:51 AM by HonzaBublik

    Simple Sliding up - doesn't work

    HonzaBublik

      Title

      Simple Sliding up - doesn't work

      Post

      I have FMP 10 on Mac 10.7. In layout as well as browse mode, I have 5 lines available, but don't want to print all five in preview and print. I tried the "Set Sliding/Printing, that didn't bring it up in Preview. When I use format show sliding - it all points UP. What am I doing wrong?

       

      Preview.jpg

        • 1. Re: Simple Sliding up - doesn't work
          philmodjunk

          The vertical lines you have added will not slide up and prevent the body from resizing to fit the data. Thus, there is no visible change when you enter preview mode. As a test, try removing the vertical lines and see if you then get the sliding/resizing you've specified.

          Key facts about sliding layout objects:

          1. It's only visible in preview mode and when you print/save as PDF...
          2. All layout objects below and in the same layout part as the slide/resize field need to also be set to slide up and resize.
          3. Objects in headers and footers will not slide.
          4. Portals will shrink/slide to fit the number of rows of records, but fields within the portal row will not shrink/slide.
          5. Fields will slide up only if Top, alignment is specified for it and will slide left only if left alignment is specified.
          6. Consistent side borders are difficult to achieve with sliding fields.
          • 2. Re: Simple Sliding up - doesn't work
            HonzaBublik

            Removed the lines (all of them) - that didn't do the trick. ANy other suggestions? Should the number of rows in the field be as long as the longest entry or one line only?

            Thanks for the explanation though.

            JB

            • 3. Re: Simple Sliding up - doesn't work
              philmodjunk

              Exactly what sliding options did you select for these fields? "only above" or "all above"? Did you select "resize enclosing part"?

              The fields shrink, they don't "grow", so you have to size the fields to be as large or larger than the largest conceivable block of text you might enter into the field.

              • 4. Re: Simple Sliding up - doesn't work
                HonzaBublik

                Got it. Now it works. I didn't have resize enclosing part - I had it with the lines. I'll try to get the lines back... if only small ones - any suggestions how to keep the lines in there though? 
                I really appreciate your help.

                Honza 

                • 5. Re: Simple Sliding up - doesn't work
                  philmodjunk

                  Best advice I can give is to not include the vertical lines. Putting them in can be very frustrating and you get different results depending on the version of FileMaker that you have.

                  If you have 11 or 12, try placing the boundary lines so that one pixel extends into a footer or trailing sub or grand summary part and see if that works. We used to do that from the header, but it didn't work perfectly and now with these newer versions, it doesn't work at all.

                  • 6. Re: Simple Sliding up - doesn't work
                    HonzaBublik

                    Thank You so much. I'll play with it, try all suggested.

                    Honza