4 Replies Latest reply on Aug 27, 2012 1:12 PM by raybaudi

    Sliding Not Working

    crestfalleen

      Title

      Sliding Not Working

      Post

      I'm trying to set up our database to print labels. We're still using the free trial as we're making sure FMP12 can do everything we need before we switch our main office computer to Mac. I have it set up to print labels but I can't get it to slide the text up when a field is blank. This is how I have it set up:

      <<Church>>

      <<First>> <<Last>>

      <<Home Address 1>>

      <<Home City>>, <<Home State>>  <<Home Postal Code>>

       

      However, on some of our entries we don't have a first or last name, it's just church, address, city, state, zip. So we want that space that is left by first and last name to be removed and the address, city, state, zip lines to be moved up. 

      I've gone into the inspector and went to Sliding & Visibility to "Remove blank space by: Sliding Up based on: All objects above" and "only objected directly above" (at different times of course), but neither of them seems to be doing anything. After doing this I go and check it in preview mode, but I still get the blank space. I've added a screenshot too so you can see. How can I fix this and get rid of the blank space? Am I looking in the right place to do this? Thanks so much.

       

       

      filemaker_pro_screenshot.jpg

        • 1. Re: Sliding Not Working
          raybaudi
          While in Layout Mode, go to menu View >> Show ( put a check to Sliding Objects ).
          All the fields must now show an arrow. Is it so ?
          • 2. Re: Sliding Not Working
            philmodjunk

            I would guess that:

            <<Church>>

            <<First>> <<Last>>

            <<Home Address 1>>

            <<Home City>>, <<Home State>>  <<Home Postal Code>>

            Is a single layout text object. If you click it in layout mode, you'll get one set of selction handles for the whole group, correct?

            That means you have an invisble "return" character as the last character on each line. This keeps any of these lines from being truly empty and thus they don't slide up.

            Make each line here a separate text object and set them all to slide up and it will work.

            To separate your existing merge fields into such separate objects:

            Enter layout mode.

            Double click the text to open it for editing.

            Drag over the top row of text from right to left, from the last visible character and select "cut" from the edit menu. (Do not copy the return).

            Click elsewhere on your layout and choose Paste from the edit menu.

            Repeat to separate out all the lines of text.

            Delete any remaining text object

            Drag your separate objects back into correct position for your address label, you may want to use the alignment tools to get them just right.

            Select them all and choose either slide up option.

            • 3. Re: Sliding Not Working
              crestfalleen

              I go the arrows to show up through View>Show>Sliding Options. Thanks raybaudi. I tried what you said PhilModJunk and I didn't get anything to change. The text that's there is from the Manage>Layouts on the upper right hand top of the window. I went in and created the label from there and it did it with text input instead of label boxes. However, I went and created a new one the same way, deleted the text labels and made label boxes and I get the to slide left for city, state, zip; but not to slide up when first and last are empty. Did I miss something I shouldn't have on your instructions guys? Thanks.

               

                

              • 4. Re: Sliding Not Working
                raybaudi

                If you do not see the arrows in layout mode, then you didn't set the sliding options.