4 Replies Latest reply on Mar 22, 2011 2:08 PM by philmodjunk

    Sliding Up Not Working

    jetmaster

      Title

      Sliding Up Not Working

      Post

      I have an invoice with the following fields:

      name

      organization

      address1

      addresss2

      city, state, zip

      these are all merge fields

      when address 2 is empty there is a space there. the city state zip line doesn't fill the space even when the SLIDE UP checkbox is selected for those items. What am I doing wrong?

        • 1. Re: Sliding Up Not Working
          philmodjunk

          Exactly how did you enter the merge text?

          Like this:

          <<name>>
          <<organization>>
          <<address1>>
          <<address2>>
          <<City>>, <<State>>, <<Zip>>

          If so, you have a carriage return between Address1 and Address2 that is present even when Address2 is empty and this prevents the sliding up.

          Try setting up the first 4 lines of this with regular fields set to slide up and you won't have this issue. (use merge field format for the last line to insert the commas and spaces where needed.)

          Key facts about sliding:

          1. It's only visible in preview mode and when you print/save as PDF...
          2. All layout objects below a slide/resize field need to also be set to slide up and resize.
          3. Only objects in the body will slide.
          4. Portals will shrink/slide to fit the number of rows of records, but fields within the portal row will not shrink/slide.
          5. Consistent side borders are difficult to achieve with sliding fields.

          • 2. Re: Sliding Up Not Working
            jetmaster

            that worked great. thank you.

            • 3. Re: Sliding Up Not Working
              jetmaster

              I did what you said and it worked great. Then I overwrote my file and went back and did it again and it didn't work?

              What could have happened the second time?

              • 4. Re: Sliding Up Not Working
                philmodjunk

                No way to tell from here. Sliding is touchy. Make sure none of the fields do not have the correct sliding options set. Make sure none touch or cross the boundary between the body and another layout part. Make sure that they don't overlap each other even by one pixel. (Don't know if that's still a possibility here, but it was back when I first used sliding fields in FileMaker 2.5!)