2 Replies Latest reply on Jul 14, 2009 10:53 AM by ravisub

    Special windows settings needed for IWP access?

    ravisub

      Title

      Special windows settings needed for IWP access?

      Post

      I've got a Filemaker Pro database shared using IWP, and as far as I can tell the settings under accounts, privileges, extended privileges etc. are all Ok (I walked through them with a customer support person). But I can only access the database as follows:

       

      1) From the local machine using the address http://localhost

       

      I can log in as a user or a guest using either Firefox or Internet Explorer and things seem fine.

       

      2) From the local machine using the ip address (http://ip-address)

       

      Only Firefox (version 3.5) works here; Explorer (version 7) gets to the login page, but when I try to log in as a guest or a user with an account, I get the following error message: "The account and password you entered cannot be used to access this file. Please try again.".

       

      3) From an external machine, using the ip address

       

      Both Firefox and Internet Explorer report the same error message as above. You can get to the database homepage, and click on the database filename to get to the login page, but then the message "The account and password you entered cannot be used to access this file. Please try again." is reported.

       

      I'm at my wits end here.. all help greatly appreciated! Thanks,

       

      -rs

        • 1. Re: Special windows settings needed for IWP access?
          TSGal

          ravisub:

           

          Thank you for your post.

           

          Perform the following steps:

           

          1. Create a new database file, Test.fp7, with one field and one record.

           

          2. Pull down the File menu and select "Sharing -> Instant Web Publishing..."

           

          3. Turn on Instant Web Publishing (if it isn't already), and write down the IP Address displayed.

           

          4. In the bottom left corner, highlight Test.fp7, and in the bottom right, set the access to "All users".  Click OK.

           

          5. Launch a browser and enter:

           

          http://<IP Address from step #3 above>

           

          6. At the Instant Web Publishing page, select Test.fp7 and enter Username: Admin with blank password.

           

          Do you receive an error message?  If not, log out and continue on.

           

          7. Go to another machine, launch a browser and enter:

           

          http://<IP Address from step #3 above>

           

          8. At the Instant Web Publishing page, select Test.fp7 and enter Username: Admin with blank password.

           

          Do you receive an error message?  If so, what is the error message?  On the host machine, do you have allow incoming connections?

           

          If step #8 works, then there is something additional about your main database file that is causing a problem.

           

          Any additional information you can provide may help in narrowing down the possible causes.

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: Special windows settings needed for IWP access?
            ravisub
              

            Thanks TSGal. This was related to my other posting asking about the proxy server. It turns out that's where the issue is, and this part of the setup does work. So if I temporarily turn off the proxy configuration, everything works as you described. There's something in the company's proxy script that causes the login screen to fail. I am going to try FM Server with the SSL support, and I will post my experience after I try it.

             

            -rs