5 Replies Latest reply on Sep 2, 2009 1:34 PM by TSGal

    Strangest Problem

    JoeMiller

      Title

      Strangest Problem

      Post

      Hi. I do I.T. support for a small organization that uses Filemaker Pro 7. Now I am not familiar with Filemaker at all.

       

      The problem is that there is a numeric field in a table which displays properly on the screen, but when the record is printed, this field prints as a different numeric value than what is displayed on the screen. What is quite weird is that the number that is printed is exactly 1 character less for each digit. For example, the number displayed on the screen is 16512. The number that prints is 05401, as if 1 was subtracted from each digit in the number before printing. The other numeric values in the record print properly.

       

      This problem popped up after installing a new printer for this user, an HP Color Laserjet CP1215. So naturally I assumed that this problem was related to the new printer. So I was shocked to find that when I connected the user's old printer, an HP Photosmart 7450, that it was still printing this number incorrectly. Yet this problem did not exist before replacing the Photosmart 7450 with the Color Laserjet CP1215. 

       

      If anyone can shed some light on this really strange problem, I would really appreciate it.

       

      Thanks very much.

       

      Joe Miller 

        • 1. Re: Strangest Problem
          TSGal

          JoeMiller:

           

          Thank you for your post.

           

          FileMaker should not send incorrect information to the printer driver.  I believe it is only coincidence that one digit less for each character is occurring.

           

          Pull down the View menu and select "Preview Mode".  This is exactly what would be sent to the print driver if you select "Records being browsed."  That is, it starts with the first record in the found set.  Look at each record in Preview mode and see if the number 05401 appears for every record or just the first record.  When you are in Browse Mode, is 16512 listed in the first record?

           

          Any additional information you can provide may be helpful in narrowing down the possible cause(s).

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: Strangest Problem
            JoeMiller
              

            Thanks for your reply. FYI the name of the field in question is Receipt #.

             

            I can confirm that whatever record I try to print, the receipt # is appearing the same way in preview mode as I described previously. In the first example I gave, receipt # 16512 appears as 05401 in preview mode. I just tried receipt # 15511. In preview mode it displays as 04400. Receipt # 16507 displays as 054/6 in preview mode.

             

            And of course the record is printing exactly as it appears in preview mode.

             

            Again this problem only began after we switched from the HP Photosmart 7450 to the HP Color Laserjet CP1215. And even though I have now switched back to the Photosmart, the problem is still happening.

             

            I am not sure what else I can tell you about this because I am not really familiar with FM.

             

            Thanks,

             

            Joe

            • 3. Re: Strangest Problem
              etripoli
                 Is there a script used for printing, or are you choosing 'Print' from the File menu?
              • 4. Re: Strangest Problem
                JoeMiller
                   Print from the File menu
                • 5. Re: Strangest Problem
                  TSGal

                  JoeMiller:

                   

                  Thanks for the additional information.

                   

                  It could either a printer driver issue, a FileMaker database file issue, FileMaker Pro issue or an OS issue.  Since this worked properly before, I'll focus on the first three.

                   

                  To check the printer driver issue, do you have access to another computer with FileMaker Pro and different printer drivers?  If so, can you copy the file to that machine and see what occurs?  If it looks fine in Preview mode, then it could be a printer driver issue, but it does rule out a database file issue.

                   

                  If the problem still occurs, close the file, pull down the File menu and select "Recover".  Select the file, let the resulting file default to Recovered and save.  FileMaker Pro will try to repair the file.  It is not a cure-all solution.  When finished, open the recovered file and try again.  Does this work?

                   

                  Do you have a backup copy of the database file prior to when the problem occurred?  If so, open the backup copy and see if it works?  If so, then the original file is damaged.  What you may want to do is export the data from the damaged file, and import the data into the backup file so you have the most up-to-date information.

                   

                  In case the application FileMaker Pro is damaged, uninstall and reinstall FileMaker Pro.

                   

                  Please continue to keep us posted with any progress.

                   

                  TSGal

                  FileMaker, Inc.