3 Replies Latest reply on Jul 15, 2014 7:59 AM by philmodjunk

    Sub-summary "breaking bad"

    quirkycrone

      Title

      Sub-summary "breaking bad"

      Post

           For some bizarre reason this report thinks that Kim Villard is 3 people.  I have tried re-entering the name.  I just can't figure why this is happening???

           All the other names seem to work just fine...

           Penelope Foran

            

      printmaker.jpg

        • 1. Re: Sub-summary "breaking bad"
          philmodjunk

               What do you get when you perform a find for Kim Villard?

               If you can pull up a found set of all "Kim Villard" records, I'd then use Replace field contents to update that field with exactly the same text for every record in the found set and see if that makes a difference.

          • 2. Re: Sub-summary "breaking bad"
            quirkycrone

                 When I pull up Kim Villard that works.   When I replace all with KV it still divides the records into crazy little groups.  Go figure.  Even when I am simply sorting on Printmaker field. 

                 Before writing this post I also tried removing the sub-summary and reinstating it.  No go, no way, no how!

                 It does seem that if Filemaker has an issue, I will find it!

                 Next I am going to recreate a virgin layout.

            • 3. Re: Sub-summary "breaking bad"
              philmodjunk

                   You might want to rebuild the index on that field as a way to rule out issues with the field's indexes. (These are used by FileMaker in searches, sorts and relationships so unusual behavior in one of these areas is once in a great while due to a messed up index.)

                   To rebuild the index of a single field:

                     
              1.           Open Manage | Database | Fields and double click the field
              2.      
              3.           Use either the storage tab or the storage options button to turn off indexing.
              4.      
              5.           Exit Manage | Database, then return and turn indexing back on.

                    

                   You can also rebuild all your file's indexes by importing all the data into an empty copy (clone) of your file.

                   If you have FileMaker 11 or newer, you can use Advanced Recovery options to rebuild your file's indexes:

                     
              1.           With the file closed, select Recover from the File Menu.
              2.      
              3.           Select "Use advanced Options"
              4.      
              5.           Select only: "Copy File Blocks as-is" and "Rebuild Field Indexes Now".
              6.      
              7.           The recovered copy of the file will be identical to the original copy except that it has completely rebuilt indexes.