1 Reply Latest reply on Mar 26, 2010 10:50 AM by philmodjunk

    Sub-summary and Summary Field Not Calculating Correctly

    Link2430

      Title

      Sub-summary and Summary Field Not Calculating Correctly

      Post

      I have a layout which on layout load performs a few finds so that only certain records are showing. This layout pulls fields from other tables. It is sorted by month and contains a sub-summary leading part sorted by Header::cMonth, a sub-summary leading part sorted by Client_Header::ClientID, and a sub-summary trailing part sorted by Header::cMonth. The layout shows a few clients (that are similar) for every month with their projected, remaining, and spent budgets. I need to somehow get a total of these numbers. I tried putting some summary fields in the last sub-summary trailing part that is sorted by Header::cMonth. 

       

      The problem is, on one certain month (the busiest one) the totals are WAY off. On the other months, they are calculating correctly.  The summary fields I have calculating as follows:

      Total of ProjectedBudget(running with restart) , when sorted by Header::cMonth

      Total of RemainingBudget(running with restart) , when sorted by Header::cMonth

      Total of OverallBudget(running with restart) , when sorted by Header::cMonth

       

      The ones that are calculating correctly have at most three numbers to total up, the March one that isn't working has 7. The number should be around 80,000 and I'm getting almost double that. On another one I'm supposed to be getting around 100,000 and I'm getting 720,000. Do you have any ideas of what might be wrong?

       

      I noticed that when I'm going through the records, even though there are only a few lines showing the next line might be 10 records later. Is that the issue?