6 Replies Latest reply on Aug 10, 2010 10:29 AM by TSGal

    Subsummary reports in browse mode

    scottworld

      Title

      Subsummary reports in browse mode

      Post

      There is a long-standing bug in FileMaker Pro when viewing subsummary reports in browse mode.

      When viewing a subsummary report in browse mode, FileMaker puts an enormous amount of unexpected blank space at the bottom of the report that enables the user to keep scrolling way beyond the end of the report into a vast emptiness.  FileMaker lets you scroll BENEATH THE LAST RECORD in browse mode. It's as if FileMaker THINKS there are 50 or 100 more records beyond the last record, but there are actually NO MORE RECORDS to scroll to. So you can scroll & scroll & scroll, and suddenly you're looking at a blank report in browse mode. Because all of the records just scrolled right off the page above you.

      But as soon as you switch into preview mode, the emptiness disappears and the subsummary report looks/prints exactly like it should.

      Can you please fix ASAP? This bug is really annoying my clients.

        • 1. Re: Subsummary reports in browse mode
          philmodjunk

          I have a summary report with subsummary parts.

          When I pull up the report in browse mode and scroll to the end of the report, I don't see any "vast emptiness". I'm using filemaker 10 and 11 in windows xp, sp3.

          Is there any more detail about your system or this report that may differ from mine?

          • 2. Re: Subsummary reports in browse mode
            scottworld

            Every subsummary report I have ever created in FileMaker Pro exhibits this behavior. This isn't a one-time thing.

            Below are several screenshots.

            Screenshot #1 is an example of one of my subsummary reports in browse mode. Notice the scroll bar on the right... you can keep scrolling & scrolling, but all you get is grey vast emptiness of nothing, like navigating into a black hole. This happens in all of my subsummary reports in browse mode.

            Screenshot #2 is that very same subsummary report in preview mode. Notice that the report ends as soon as the last line appears on the report. This is NORMAL and this is how it should work! 

            Screenshot #3 shows that very same subsummary report in layout mode. Nothing unusual at all. I've tried adding many other layout parts as well to fix this bug, such as adding a trailing grand summary or a footer or a title footer, but nothing fixes this bug.

            This bug happens on ALL of my subsummary reports, not just this one.

            • 3. Re: Subsummary reports in browse mode
              philmodjunk

              Perhaps this is a Mac only thing as I don't see this behavior on my windows system. I suggest making an issue report in Report an issue so that TSGal or another filemaker rep can confirm this. You can include a link to this thread by copying the text in the URL box at the top of your browser and then pasting it into your issue report.

              • 4. Re: Subsummary reports in browse mode
                scottworld

                Thanks, Phil. I will do that.

                • 5. Re: Subsummary reports in browse mode
                  scottworld

                  Just to clarify the problem here:

                  The problem can't be solved just by adding a white footer or by changing the background to all white. The grey background is just to help you guys visualize the problem. Even with a completely white background in all layout parts -- or adding a white footer --  the problem is still the same.

                  The problem is that when in browse mode, FileMaker lets you scroll down waaaay beyond the bottom of the report, waaay beyond the last record. So you end up staring at a blank screen of nothingness, as if you have an empty report, even though all of your records are really up at the top. You just happened to scroll beyond all of them. 

                  It's as if FileMaker thinks that there are "invisible records" that live underneath your found set of records... but there are really no more records to look at.

                  • 6. Re: Subsummary reports in browse mode
                    TSGal

                    scotty321:

                    I have responded to your post at:

                    Screenshots of the subsummary bug in FileMaker Pro

                    In essence, the problem is known by our Development and Software Quality Assurance (Testing) departments, and this issue does occur on both Mac and Windows computers.

                    TSGal
                    FileMaker, Inc.