1 Reply Latest reply on Mar 31, 2011 10:09 AM by philmodjunk

    subsummary total not printing even though it is calculated correctly

    macguy918_1

      Title

      subsummary total not printing even though it is calculated correctly

      Post

      I created a report that has subsummary totals for three fields: category, subcategory, and class in that order.  The file is sorted correctly and the subcategory and class subtotals print fine.  however, even though I have the print format set the same for all three subsummary fields (currency, 2 decimals, right justified) the category subsummary fields just displays a question mark.  If I click on the question mark I see the correct subtotal but it has 14 digits to the right of the decimal point and it won't display the number with currency formatting per the layout.

      Anyone know what could cause this?

      thanks

        • 1. Re: subsummary total not printing even though it is calculated correctly
          philmodjunk

          Make the fields wider. If the field is too narrow to display all the digits for the format options you selected as well as any specified currency symbol, you'll see the question mark. When you enter the field, you'll see the unrounded, unformatted field, which is why you see all the extra decimal places.

          Keep in mind that the inspector changes how the number is displayed, it has no effect on what value is actually stored in the field. Those extra decimal places may be necessary to get accurate calculation results or they may not be significant and could result in incorrect evalutation in other calculation fields, script steps, finds, etc. It depends on what the numbers represent.

          Most currency fields are best rounded to two decimal places instead of just being formatted to display two decimal places, but there are many exceptions.