1 2 Previous Next 22 Replies Latest reply on May 17, 2012 12:49 PM by C.Kobel

    Table View Issues

    b4farmer

      Title

      Table View Issues

      Post

      I've been working on this one for about 3 days now with no luck. I am trying to add columns to my table view. I click on the modify button, the field I want is not listed so I click on the green + at the bottom of the screen. I find the fields I wish to add, select them and click OK, but the do not appear in my "Modify Table View" list at all. 

       

      I wondered if the list can only hold so much, but was unable to delete anything from the list. Everything in there has the locks on and the trash can is grayed out. My main database has 560 fields, however I'm only trying to display 10 in Table View. Currently there are only 8 up. Why can't I add to this list? What am I doing wrong?

       

       

        • 1. Re: Table View Issues
          mrvodka
             If you want to permanently add them to the layout, you should add them in layout mode.
          • 2. Re: Table View Issues
            b4farmer
               I'm sorry maybe I must be missing something. Switching to layout mode takes me out of table view. I tried clicking on the pencil and changing my Menu Set to Custom Menu Set 1 from File Default. That didn't change anything. I not sure where I'm supposed to be I guess.
            • 3. Re: Table View Issues
              mrvodka
                 Go into layout mode and drag the two fields you want on the layout. Then go back into browse mode.
              • 4. Re: Table View Issues
                b4farmer
                   The stuff I want is already in my main layout (Form View), just will not come up in table view. I can't seem to drag anything into table.
                • 5. Re: Table View Issues
                  etripoli
                     Where in the layout are the fields?  The Body, Header, Footer, etc?  And, to clarify, are you switching the same layout betweem form and table view, and missing fields?  Or are these 2 different layouts?
                  • 6. Re: Table View Issues
                    b4farmer
                       It's all in the body, and yes switching the same layout between form and table view and missing fields that way.
                    • 7. Re: Table View Issues
                      mrvodka
                        

                      1. Go into layout mode on the layout where you want your table view.

                      2. Go to the view menu and turn on the Status Toobar if it is not already on.

                      3. Find the field tool on the toolbar ( next to the format painter and part tool ).

                      4. Click the icon, hold, and drag to that main layout.

                      5. Specify the fields that you want.

                      6. Go back into Browse mode.

                      • 8. Re: Table View Issues
                        mrvodka
                          

                        b4farmer wrote:
                        It's all in the body, and yes switching the same layout between form and table view and missing fields that way.

                        Try creating a new layout. Do you still ahve the same issue?


                        • 9. Re: Table View Issues
                          b4farmer
                             Ok. I now have that field appearing twice (in the body) of the Form view, but can not get it on to appear on the table view. When I created a new layout however, it worked. What does that mean? Is there a way to fix the first one?
                          • 10. Re: Table View Issues
                            etripoli
                               Exactly where on the body of the layout is the field?  It could be that the field is touching the line dividing the header from the body, and so it appears that the field is in the body, shen you are viewing in form mode.  If that is the case, move the field(s) down 1 pixel.
                            • 11. Re: Table View Issues
                              LaRetta_1
                                 I know you said you only have 8 fields in table view.  But if they are all comment fields, they could be taking up the max width for the table.  Try resizing your fields to much smaller (and try even deleting a different field) to see if it makes a difference.
                              • 12. Re: Table View Issues
                                b4farmer
                                  

                                Ok I took it down to where I only had one field showing in the table view and it still doesn't show me the particular field I'm looking for. When I click on the Modify button it's not even appearing in the list with the check boxes and the padlocks. After clicking the green Plus button and finding it in the list there and click OK to add it to the first list... it still doesn't appear in the Modify Table View list.

                                 

                                On the Form View side of things, it appears a good 4 inches down from the header line so I don't think that's it. It's appearing below other things that are showing up on this list. 

                                • 13. Re: Table View Issues
                                  TSGal

                                  b4farmer:

                                   

                                  Thank you for your post.

                                   

                                  Try creating a new Standard Layout.  All fields should now appear.  Switch to Table view.  Does your field now show?  If not, what is the name of the field, and what is the field type (text, number, date, etc.)? 

                                   

                                  TSGal

                                  FileMaker, Inc. 

                                  • 14. Re: Table View Issues
                                    b4farmer
                                       Thanks for the suggestion. I did try this and was able to see everything in the list on the new Standard Layout. Because this particular database has 590 fields, I'm using my original form view and I created a button to jump me to the new layout's table view. Is that a bad idea or a good work around? I'm not trying to cause myself problems down the road.
                                    1 2 Previous Next