1 Reply Latest reply on Apr 22, 2012 8:34 PM by KatG

    text size changes with copy/paste into fields

    KatG

      Title

      text size changes with copy/paste into fields

      Post

      I am trying to use Dragon Dictation, copy the text and then paste into the respective fields. When I paste, it changes the size to 7pt, even though the field is set for 18. Is there a way to "lock" the field settings to ignore size, font and color changes? I am Using FP 12 Trial version. Thanks!

        • 1. Re: text size changes with copy/paste into fields
          KatG

           

          I founf this post by PHILMODJUNK from July 2010 . I changed the "search" wording and it came up. You rock Phil!

          Best way to remove the formatting:

          Step 1:

          1. Go to a layout where this field is displayed, select Show All Records and click in the field.
          2. Choose replace field contents from the records menu.
          3. Specify "by calculation" and enter an expression: TextFormatRemove ( YourTable::YourField )
          4. Do the replace.


          Step 2:

          1. Find this field's definition in Manage | Database | Fields and double click it.
          2. Select the auto-enter tab
          3. Select the calculation option and enter: TextFormatRemove ( Self ) and clear the "do not replace existing value..." check box.

          Step 1 fixes your existing data, Step 2 keeps it from happening in the future. When it comes time to format your data for output, it's usally best to select the field while in layout mode and specify a format for the field instead of formatting the text itself.