7 Replies Latest reply on Jun 21, 2015 12:44 PM by hoib

    Time Field - stuck as a "Decimal" - Inspector unable to change it

    hoib

      Title

      Time Field - stuck as a "Decimal" - Inspector unable to change it

      Post

      Here's a strange one.  And maybe it isn't.  Who can say?  On Win 7 Pro with FM14 Pro Adv.

      I have a time in field on a timesheet layout.  In the source table, this "Time_In" field is set as a "Time" type.  Not Text or Number or any thing else.  Over on the layout which is based on that TO, the field is set in place in a portal that brings in the volunteer's info.  I use a drop down with a custom val list to pick the time in, in 15 minute increments and formatted hh:mm.  The layout is giving me a displayed value like this example:  9:15:46 AM    I don't want seconds displayed which causes the field to wrap - I'd just like to see 9:15 AM.  Pull up the inspector.  It shows that the field is set to display "Decimal" values.  That doesn't look right so using Inspector I shift that element over to the Time setting in the Data Formatting section under the Data tab, and ensure that I have 12 hour set and ":" as the separator.  Also the format is set to hh:mm.  All looks good.  Go to save this layout.  No change to the field display.  Back to the inspector and it's back to Decimal again!  The change I just imposed did not persist.  And, funny to note, I checked on other time fields that display correctly - they're all Decimal too!!!!

      Question:  Are all Time fields supposed to be in Decimal Format (in the Inspector)?

      So in order to fix this display problem, exactly what am I looking at here?  I'm sure if it was a FM "bug" someone would have recognized it by now.

      I'm duly perplexed.  Anybody know what I should do?

      Hoib

        • 1. Re: Time Field - stuck as a "Decimal" - Inspector unable to change it
          philmodjunk

          Is this what you see for your time fields? This is normal. Notice that the "Decimal" format is greyed out. It is not selected. It's just the case that "number" formatting options are the default selection in the inspector. If you then click the "clock" button to select the time formatting options, you'll then see the time format options specified for your time field.

          • 2. Re: Time Field - stuck as a "Decimal" - Inspector unable to change it
            hoib

            Phil - thanks for the input.  In the Inspector, I do click on the clock.  Set those settings/fields as I should.  What is strange is that we're all used to "Exit Layout" and get the prompt to save the layout.  In my case "Exit Layout" when I change these settings does not come up.  So the changes are not getting saved to the object on the Layout.   And I cannot figure out why I can't.  I've attached two screenshots to show you what I'm seeing - same as yours!

             

            When you change yours to "Clock", do your settings persist?  Or do they stay at Decimal?

            Appreciate any further insight as to why the settings on the clock (Time Formatting) do not persist.

            Thanks a lot.

            Hoib

            • 3. Re: Time Field - stuck as a "Decimal" - Inspector unable to change it
              SteveMartino

              I would try a few things, just to check.

              1.  Open up that layout, nudge a field one pixel, Exit Layout, see if you get your prompt to save changes.  Also note when you change anything in layout mode, the Save Layout button goes from gray to normal. 

              2.  Open up in layout mode, change your clock settings, click back on a field.  Does the Save Layout button change from gray to normal(clickable)? If it doesn't and you move the field one pixel, does the button now become clickable.

              3.  Remove the field from the layout, put it back on.

              • 4. Re: Time Field - stuck as a "Decimal" - Inspector unable to change it
                philmodjunk

                The image on the left means nothing. You can't see the specified data format options for a given time field until you first click the Clock option in the Inspector.

                There is a preference setting to "save layout changes automatically" that might be selected that is keeping the layout save option from appearing.

                Plus, if you are setting data format options that are already selected for the current field, that might not trip the "save flag" that causes this dialog to appear as you haven't actually made a change to your layout.

                I am quite aware that none of this resolves the problem you are reporting, but I'm trying to first clear up some preliminary confusion over what you are seeing on your computer screen so as to better zero in on the issue.

                Next detail that can cause confusion. The data format options in the inspector or for printing/display purposes. They do not affect what you see at the time you have the cursor in the field in order to select/enter a value. They kick in when you leave the field and if you re-enter, you once again see the actual value as it is entered in the field.

                • 5. Re: Time Field - stuck as a "Decimal" - Inspector unable to change it
                  hoib

                  @STEVE.  Moved it one pix.  Exit Layout brings up the Save prompt.  OK.  Removed field from the layout (portal row).  Replaced with the same new field using Field Picker.  Poof!  Solved.

                  @Phil - What I was trying to do with the first image was show how it is now. And how it looks after I leave and come back.  I wasn't clear in my illustration.  I understand invoking the "Clock" will open up the added options for time formatting.   It just seems logical to me that if I go from Decimal to Clock formatting, that constitutes a fundamental change in the way the layout (portal row) displays.  Thus I should get a "Save" prompt but don't.  Apparently that is not the case with FM.

                  And in sum, even though now that it works and displays correctly, the Inspector insists on showing this time formatting as Decimal.  So I created a blank layout, put some of my time fields on it.  Inspector shows them as Decimal.  Click the clock, set some formatting to show hhmmss on one and 24 hour on another.  Exit layout > Save layout works as advertised.  Browse mode shows these new display values successfully.  Back to layout mode.  Oddly, Inspector is right back again with Decimal. 

                  And as you point out Phil, this is by design.

                   

                  Hoib

                  • 6. Re: Time Field - stuck as a "Decimal" - Inspector unable to change it
                    philmodjunk

                    I understood that, it just wasn't something that was going to resolve the issue and it appeared that you thought that what you saw when you first selected the field and checked this part of the Inspector was showing the actual format options selected for the field when it does not do so.

                    To repeat: it is NOT showing the formatting as decimal. You are simply seeing disabled default values for a number format not actually applied to any object on your layout. Click the Clock button and then you see the selected time format options.

                    What you probably haven't realized is that some layouts, such as a block of layout text with several merge fields inserted into it, can have number, time and date formatting options all selected for the same block of text.

                    • 7. Re: Time Field - stuck as a "Decimal" - Inspector unable to change it
                      hoib

                      OK, thank you Phil.  Learn something everyday here.

                      Hoib