9 Replies Latest reply on Feb 1, 2010 2:17 PM by LaRetta_1

    Timestamp display issue

    thingmaker

      Title

      Timestamp display issue

      Post

      Hello, I am having issues with dates being displayed incorrectly. Since our company works with people in EU and the US, we decided to use the EU format for date: 21-Feb-2010. 

       

      The problem is that the no matter what the date is, it is displayed as 01-Feb-2010 instead of 21-Feb-2010 or 13-Feb-2010. It always shows 01 instead of the correct date. If you click on it, it shows the correct date.  

       

      - the record is of the type Timestamp (options: modification, Time and Date) 

      - It displays incorrectly whether viewed online as a web published database or if opened remotely.

       

      This happens on all of our databases. Does anyone know why this happens? Thanks. -Derryl 

       

        • 1. Re: Timestamp display issue
          philmodjunk
             This is an idiosyncrasy of Filemaker Time Stamp fields. Because this type of field displays both time and a date, you must select a time format as well as a date format for the field before either format setting will affect the appearance of the data stored in the field.
          • 2. Re: Timestamp display issue
            thingmaker
              

            Yes, Phil I am aware of this idiosyncrasy and I did select the formats as you suggested. I think this is something different. If you have quicktime you can view this example to see what I mean:

             

            http://www.4dmaze.com/images/other/FM-date.mov

             

             

            • 3. Re: Timestamp display issue
              philmodjunk
                

              I was able to watch the movie but could see anything. I saw a mouse cursor briefly appear and disappear but didn't see formats being selected in Layout mode for the field.

               

              Here's what I just did on a filemaker file to test.

               

              I added a time stamp field to the current layout, clicked into it in browse mode and inserted the current time.

              I switched to layout mode and selected Format | Date: I gave it the format you described, Day-Month-Year.

              I then selected Format | Time and selected a time format (HHMMSS, 12 hour format, etc.)

               

              In browse mode I now see: 29-Jan-2010 3:07:47 PM

               

              Isn't that what you wanted?

              • 4. Re: Timestamp display issue
                thingmaker
                   Phil, yes of course that is what I wanted but that is not what I am getting. Where the '29' is your example, I always see '1' in all of my databases. The month and year appear correctly but not the day of the month which never changes. -Derryl
                • 5. Re: Timestamp display issue
                  philmodjunk
                    

                  Ok, I went back and looked at the Video again.

                   

                  What you are describing is that when you click into the field, the format reverts. That's a standard feature of filemaker. To change what you see here, you have to change the regional settings for your computer.

                  • 6. Re: Timestamp display issue
                    thingmaker
                      

                    Phil, it isn't just changing the format, it is changing the date. From 19-jan-10 to 1-jan-10. This can't be considered a feature.

                     

                    I changed the regional settings on my computer and it still does the same thing (except the numbers are switched now). Plus I can't expect people from all over the world to change to US settings even if that was the solution.

                     

                    I really think this is more of a bug. -Derryl 

                    • 7. Re: Timestamp display issue
                      LaRetta_1
                        

                      Hi Derryl,

                       

                      You are using Custom date format (select field and Format > date).  Can you provide a picture of it?  I ask because, I've found two ways of replicating the behavior by modifying the Custom date (both require inserting a 1).  

                       

                      UPDATE:  It sounds like it might be a bug but I'd just like to eliminate the Custom date setting possibility entirely. 

                      • 8. Re: Timestamp display issue
                        philmodjunk
                          

                        It may be a bug, but it's not one that I can reproduce on my system (filemaker Pro 10v3, Windows XP).

                         

                        I formatted a timstamp field to the format you describe.

                        I enter 1/19/2010 4:55 PM

                         

                        and I get 19-Jan-10 4:55 pm

                         

                        I then used the Regional Settings control panel to switch to "United Kingdom".

                         

                        I enter 19/1/2010 4:55pm

                         

                        and I get 19-Jan-10 4:55 pm

                         

                        I also tried entering a series of other dates--including January 1--and all display the correct date and format when I exit the field.

                         

                        See anything different between what I am doing and what you've done?

                        • 9. Re: Timestamp display issue
                          LaRetta_1
                            

                          I thought it might be layout-level custom date format (since I can replicate the exact break in two different configurations, as I mentioned) but another issue could be mismatch of regional settings (in the data).  When a file has data (which was created under US m/d/yyyy) then it is important to clone the file (empty) and then import the data back in (this will convert the dates from prior to current).  Was that done? 

                           

                          Can you do a search for ? in the date field to see if there are any invalid dates?  Regardless, the results (at the data level) won't ever be 21-Feb-2010 because that is not a real date (to FM).  It would be 21/2/2010 and the layout would handle the formatting for display from there.

                           

                          Just a few more considerations. :smileyhappy: