3 Replies Latest reply on Aug 12, 2013 10:12 AM by philmodjunk

    Trouble importing files from Go to Pro

    JosephPalmer

      Title

      Trouble importing files from Go to Pro

      Post

           I created a database in Pro.  I then saved a copy, put it in Dropbox, opened it on my device in FM Go.  I have created new records in FM Go.  I used iTunes to get the database file back onto my desktop and would now like to import them into my database in Pro.

           I choose Import Records > Files...

           When I do this the new records appear in my database, but the portal information doesn't show up in Pro. 

           Have I missed a step?  Please advise.

           Thank you.

        • 1. Re: Trouble importing files from Go to Pro
          schamblee

               You have to import the records for each table in the database.   Openning a layout opens the table assoicated to that layout, so you will have to go to each layout with a different table and import the records into that table.  You can script your import.

          • 2. Re: Trouble importing files from Go to Pro
            JosephPalmer

                 When I import the other tables those records are duplicated even though I chose to only import new records. 

            • 3. Re: Trouble importing files from Go to Pro
              philmodjunk

                   THere is no such import option for import records. Likely you chose the "add new records" option and this adds all imported records as new records. To keep from importing data already in your table, you'd either limit the found set of imported records to those that don't already exist in the target table (such as finding all records with a serial number larger than that of the record with the largest serial number in the target table) or you can show all records in the target table and then use the Import matching records option with the add new records if no match option selected--but keep in mind that this only matches against records in the target table's found set--which is why you need to show all records before you start importing.