3 Replies Latest reply on Dec 3, 2014 2:17 PM by StephenBronstein

    Trouble with copying records into an existing Filemaker Database

    StephenBronstein

      Title

      Trouble with copying records into an existing Filemaker Database

      Post

      I have an application that has been in use in my office for a couple of years. I decided to add an entirely new area and functionality to it. I worked on a copy for a couple of months during which the old database was still in use.

      I did not change anything in the old database, the two functions were related in only one table and I did not need to change anything in that one table. The old section of the database is unchanged and untouched in the new application.

      Once I had completed the new section, I had to import the data from the old version (the source) into the new version (the target). When that was done, I tested the new version and immediately ran into errors. After a good deal of digging I discovered that the record pointers to unique file keys were pointing at incorrect record keys. To explain further, whenever I need a new record, there is a key field that is Indexed, Auto-enter Serial, Always Validate, Required value, Unique. It is generated On creation. The "Next Value" in the Field Options Dialogue box is listing a record that has already got data in it rather than empty. So things get confused and an error is generated.

      In portals, data shows up unrelated to the key field.

      The first time I tried to import records, I used the "Add New Records" option. It created lots of problems so I tried the "Update Existing Records in the Found Set, and checked "Add remaining data as new records."

      This import appeared to run correctly, but then I discovered the serial number field problem mentioned above. It is everywhere in the application where I add new records. So I guess my questions are, how can I import these old records into the new version without creating the above problem? How should the "Import Action" check boxes be selected to import data in my situation?

      Secondly, is there a way to move all of the "Next Record" pointer to an empty record in all of the tables in mass?

      I sure appreciate anyone's help on this. I've put a lot of time into it and I need to make it work.

      Thanks

      Steve