0 Replies Latest reply on Apr 7, 2011 8:05 AM by CraigHanna

    Trying to select from FileMaker Pro11 Advanced Server table using ODBC driver (Windows 32bit)

    CraigHanna

      Title

      Trying to select from FileMaker Pro11 Advanced Server table using ODBC driver (Windows 32bit)

      Post

      My objective is to select data remotely from a FileMaker Pro 11 Database Server.  The remote application is ASP.NET using C#.  I have a small C# ODBC tester that someone posted.  I am able to connect to the server but when I run a basic command to SELECT from the table I get the following error.

      Error:  FQL0002  The table named "xyz" does not exist

      Okay, a little background on what I have done and rechecked.  Working with the FileMaker Pro DBA we have made sure the ODBC connection is shared and read only permissions are set on the FileMaker table occurrance.  I installed the ODBC driver on my 32 BIT windows laptop.  Created a DSN and have a successful Test to the database.  Here is the connection string I end up with for connecting to FileMaker from the C# application.

      DSN=CRYO;UID=cnh;SDSN=bank_stock;PWD=*****;

      I restated the database setting although it is properly configured in the DSN configuration. 

      Here is my select statement.

      select "vial_id" from "vial" where ("vial_id" = "048A")

      This is the statement that triggers the FQL0002 Error above.  The table named "vial" does not exist.

      Fishing around I tried this also.  Notice I added _VIAL to the table name.  The DBA suggested this having a better understanding of FileMaker DBMS.

      select "vial_id" from "vial_VIAL" where ("vial_id" = "048A")

      The statement triggers FQL0007  The column named "048A" does not exist in any table in the column reference's scope.

      Anywhere I try single ticks an invalid SQL statement is thrown.  I have put in a request with the DBA to grant my account complete access simply for a quick test.

      ALL SUGGESTIONS ARE APPRECIATED.  I am running out of ideas and really need this to work.

      Regards,

      Craig.