3 Replies Latest reply on Mar 3, 2014 7:27 AM by FabienneChristenson

    Turning Off Rounding in Inventory Pre Set

    FabienneChristenson

      Title

      Turning Off Rounding in Inventory Pre Set

      Post

           Hello, I am playing with a starter solution for an inventory table. I need to be able to take out parts of units and to show parts of units on hand. However, when I record that I took out .5 of a unit from inventory, it rounds up the withdrawal to 1. How can I show that I took out part of a unit? I have tried to edit the layout and use the inspector, took the Data formatting From General to As Entered and more but I still cannot withdraw part of a unit. Can you tell me how this is done? Thanks. 

        • 1. Re: Turning Off Rounding in Inventory Pre Set
          RickWhitelaw

               Check to see if the field into which you enter your withdrawal has an auto-enter by calculation. Also check validation and the presence of a script trigger.

          • 2. Re: Turning Off Rounding in Inventory Pre Set
            philmodjunk

                 And Data formatting might be set up on the field to display rounded results. You'd use the Inspector while in layout mode to check for that.

            • 3. Re: Turning Off Rounding in Inventory Pre Set
              FabienneChristenson

                   Thank you for answering. I did look at the layout by the inspector. There was no mention of rounding on the inspector. I did try just about every form of input method and they all yielded the same results, a .5 withdrawal was rounded up to a withdrawal of 1. I did check to see if I could "auto enter by calculation" and that was not an option. I hope I am looking in the right place, it was the inspector.

                   As for validation and a script trigger, that is where it was by default! In edit layout, I double clicked on the field I was trying to edit, that brought up a box "specify filed" where I highlighted the field I wanted to change and clicked the edit button on the lower right. That brought up another box "manage database for inventory" and the field was there with a "indexed, auto enter calculation replaces..." which looked like what you were referring to. I double clicked that and another box came up "options for field Units Out, and I looked on the tab Auto Enter for the calculated value (a small checkbox with a box to the right which said "specify". Another box opened showing all of the fields in that area and what calculations were associated with them. Sure enough rounding was associated with units out, it was something like: round if self<0;self>0 (it was more elegant than that but it meant round the number in all cases). Then I deleted the calculation and saved it all. Now I am going to save it all and It works perfectly! Thank you. I was starting to get pretty frustrated by that. 

                   I think the lesson I learned about FileMaker from this is to dig deeply. Again, thanks.