2 Replies Latest reply on Jun 24, 2009 10:03 AM by pvhaute

    Unable to over-write previously created pdf

    pvhaute

      Title

      Unable to over-write previously created pdf

      Post

      Hi,

       

      I have a script that exports records to a PDF in a first step, and puts this pdf-file in a container in a next step.

       

      When repeating the export a number of times (i have the impression that it occurs from the 3rd time onwards) (with the same filename) FM gives an errormessage indicating that it cannot over-write an existing file ("i should use another filename, expand my storagespace, change the disk, ...").

       

      When i tried to delete the pdf-file, Finder (i'm using a Mac) didn't allow me to do that either saying that the file is still in use.

       

      I guess that 'access-rights' have not been closed properly after having written the last time (or when pulled into the container?).

       

      Does this sound familiar to somebody?

       

      Thx for your feedback,

       

       

      P.S. i'm running FM remote on my Mac, but the server runs on Windows (and the files i'm referring to above are on the server)

       

        • 1. Re: Unable to over-write previously created pdf
          mrvodka
             This usually is commonly seen when you have the PDF open for preview. If its not open, then try closing Adobe first before you run your script again.
          • 2. Re: Unable to over-write previously created pdf
            pvhaute
              

            Thanks for the reply,

             

            I tried all that, but to no avail ... what i tested now however is to write and export the PDF to a local folder (instead of to a server-folder before) and it seems to work fine ... for those who understand a bit more about Mac/Microsoft-combinations: i think it has to do with a file-(un)locking in the Microsoft-environment that isn't recognised by Mac (or vica versa) ... i am still interested in the solution here (but i'm already happy that it works for me now ;o) )

             

            Thanks for the efforts!