7 Replies Latest reply on Mar 10, 2013 6:15 AM by JimMac

    Unable to set default font

    PeteTheFreeze

      Title

      Unable to set default font

      Post

           Dear all,

           I am having trouble setting the default font. I did the following:

           1. enter layout mode

           2. change font

           3. go to browse mode

           4. When I go back to layout mode the font is OK! I am happy!

           5. Close file

           6. re-open file

           7. Got to the layout where I changed the font.

           8. enter layout mode

           8. The font is back to where it was before step 1. Booh-- sniff...

            

           What am I doing wrong here?

            

           Thanks in advance!

        • 1. Re: Unable to set default font
          JimMac

               What is your platform Mac or Windows and FMP version?

               Did you verify the font change by entering it in the Browse Mode to verify the change?

               How are you opening the file from your desktop?

               Jim....

          • 2. Re: Unable to set default font
            PeteTheFreeze

                 Using FMP Advanced 11 on Windows 8. Opening the file on a server 11, as Full Access. I verified the change by going to layout mode and back to browse mode and back to layout again.

            • 3. Re: Unable to set default font
              JimMac

                   Try creating a new record  and enter into a field that changed  fonts to verify the change took place.  then go back to layout and verity again.   close and reopen.

                   How do you "launch" this DB when you open the file?  Double click on FMP icon and use "Open Remote"??

                   It sounds like the layout is not being saved?

                   Jim...

              • 4. Re: Unable to set default font
                PeteTheFreeze

                     Hi Jim,

                     I haven't changed the font of any of the fields on the layout. They are perfectly fine. I want to change the default font (by changing the font while nothing is selected in layout mode), so that the next time I enter layout mode and create a new field, its font is set to this new font. This works while the file stays open. When I close and re-open any new field uses the old font.

                     And I launch it by using double-clicking FMPA11 icon and "open remote".

                • 5. Re: Unable to set default font
                  JimMac

                       Let me refer back to your original sequence and terms.

                       Default Fonts are set in preferences, but I think what you are trying to do is set the Font info for the next layout you are going to modify or create.

                       Lets call that "Design" font for just this discussion.wink

                       What I am about to tell  you may be wrong...

                       Because...

                       I don't change fonts on a the Master Server File by "open remote".  I think is it is bad practise plus others can be chaning fonts and doing the same. Server Fonts may be different too.

                       I will go with what works on a local FMP file and hope the Server is not an issue.

                       Try this on a NEW LAYOUT for a test and perhaps a test file since i was confusing you by my questions.

                       1) enter layout out mode and note the "Design" [intial] font info.

                       2) Change the "Design" Font info to something wild like DingBats or other font you NEVER use.

                       3) Create a new Layout, Standard, and select DEFAULT!

                       4) Finish the New Layout with some fields and labels in it.

                       5) enter the browse mode and PLEASE enter a new record and see if the font changed to the Dingbatangel

                       IF yes... close the file , reopen it, repeat step 1) above.  I bet the "Design" [initial] font is Dingbats.

                       IF no.. then my MacOS is different.

                       Two points...

                       1) You must set your Design Font for a NEW LAYOUT

                       2) Many selected layouts use their own fonts from the many pre-designs and switch Fonts.  So the Layout is Saved with the Font.

                       Jim...

                        

                        

                  • 6. Re: Unable to set default font
                    PeteTheFreeze

                         Thanks for your reply.

                         I converted my solution to Filemaker PA 12, because I thought FMP12 would make more sense than 11. When I try step one in your post, I cannot select a font. It's Arial, but greyed out. See picture. (I never set anything to Arial; I never used that font, so I have no idea why it is there.) When I create a new field, it is set to Arial, which I don't want.

                         One step further away from my goal it seems. When I create a new layout (Layouts->New Layout->Standard form->Classic) as per your suggestion it shows font Arial (in a new record), which is the one I never used. I checked the Preferences->Font->Western font and it was seet to Arial. I changed that to Trebuchet, opened a file and created a new layout. Still Arial.

                         I think I will choose the easiest solution and change all the fields in my solution to Arial, since that is the one Filemaker chose to use and I cannot resist Filemaker. I would have been nice if I could just follow the manual, which states:

                          

                          

                                                                                     
                                        
                    1.
                                   
                                                        
                                                                                                                         
                                             
                    2.
                                        
                                             
                    Click Inspector Inspector button in the layout bar, then click Appearance.
                                        
                                                                                                                         
                                             
                    3.
                                        
                                                                  
                    Use the Text area to format the style, size, font, or color of the text or make text highlighted, bold, italic, or underlined. Use the Paragraph area to set paragraph alignment, indenting, and line spacing for fields. For more information, see Specifying paragraph attributes and tab settings.
                                                                                                                         
                                             
                    4.
                                        
                                                                  

                          

                    • 7. Re: Unable to set default font
                      JimMac

                           Enterth the new world of FMP 12 THEMES and ye shall follow the Theme into the wilderness.laugh

                           Except Classic...

                           You can do a Select All type [for windows i think is Ctrl Alt A] which if you select a label type and do a select all type will allow font change all at once.

                           This whole discussion becomes moot with FMP 12.

                      http://help.filemaker.com/cgi-bin/filemaker.cfg/php/xml_api/cci/fm_show_ans.php?p_faqid=10785&p_sid=72740905

                           I dislike Tahoma font too.  I think I had a flat tire passing through a town named Tahoma once.

                           Have Fun...

                           Jim...