4 Replies Latest reply on Nov 17, 2008 2:52 PM by TSGal

    Unexplainable gap when using sliding in FMP 7...

    BP

      Title

      Unexplainable gap when using sliding in FMP 7...

      Post

      For the life of me I cannot figure out why I am getting a gap in my layout! Everything is set to slide up (and the graphic elements are set to align top/left as previously recommended to get graphics to slide correctly).

       

      I have posted one pic that contains an example of the way I want it to slide and they way it doesn't all in one image here:

       

      http://imagecloset.com/view18/f68f9aaebf359aa318bb03d36ed4935a/sliding%20problem.jpg

       

      If you scroll through the image you will see my problem.

       

      Any thoughts!!??

       

      Thanks for your help!! 

        • 1. Re: Unexplainable gap when using sliding in FMP 7...
          Dirk
            

          Hi BP,

           

          In Format - Set Sliding/Printing, did you also tick 'also reduce the size of the enclosing part'?

          And did you apply this to all the fields on your layout?

          • 2. Re: Unexplainable gap when using sliding in FMP 7...
            BP
              

            Yes... every item is set to slide "based on all above" and I have checked "also reduce the size of the enclosing part".

             

            And as my graphic image shows if I delete certain text fields and leave only the five graphics on the right, every record will slide up close to the one above it... But with those text fields in place, I get the variable sized gap between records.

             

            It just doesn't make sense... 

            • 3. Re: Unexplainable gap when using sliding in FMP 7...
              TSGal

              BP:

               

              Thank you for your post.

               

              It doesn't make sense to me, too.  However, there is probably something on the layout it doesn't like, and it's hard to determine what it is without seeing the file.

               

              If I was to receive the file, I'd first look for information in the lower fields, like a space or accidental return.  Even though you can't see it, the character would cause it to not slide up, or limit the amount something would slide upwards.

               

              If you want, I would be happy to look at the file for possibilities.  I have sent you a private message (top of this page - right side - X Messages) with instructions where to send the file.

               

              TSGal

              FileMaker, Inc. 

              • 4. Re: Unexplainable gap when using sliding in FMP 7...
                TSGal

                All:

                 

                BP did send in his file, and I was able to look at it.  I forwarded the information to our contact in Technical Support and he should be sending the file back to you shortly.

                 

                In essence, there was several fields, but there were vertical gaps between each field.  I sized the fields larger - not font size, but I took the field handles and sized the field larger to remove those gaps.  Now, everything slides up correctly.

                 

                If you don't receive the file shortly, please let me know, and I'll follow up with our Technical Support contact.

                 

                TSGal

                FileMaker, Inc.