10 Replies Latest reply on Dec 13, 2014 2:46 PM by philmodjunk

    Unlock Field?

    NicholasPotter_1

      Title

      Unlock Field?

      Post

      I want to add and remove fields from different tables within one database. But I can't change the available fields once I click into the Modify tab. I think this might be because the fields have the locked icon next to them. If this is the case how do I unlock fields?...

        • 1. Re: Unlock Field?
          philmodjunk

          You are not removing fields from or adding them to a table. You are including or excluding them from a table view. And you can use the modify button to remove even fields with the "lock" icon from your table view by clearing the check box. You can add fields not listed from your table view by clicking the Plus sign button at the bottom of the Modify dialog. The trash can icon simply removes the field from the default list of fields in the Modify dialog. If a field has been added to your layout while in Layout mode, that field will show a lock icon showing that it cannot be removed from the modify dialog (but it can still be excluded from the view)

          And none of these actions actually add/remove field from the table where they were defined.

          • 2. Re: Unlock Field?
            NicholasPotter_1

             

            Thanks for your reply. This is the approach I have used in the past but for some reason I cannot add or remove fields in the modify tab anymore. I have attached a screen shot of the set-up. When I highlight the field I want to add and click "OK", nothing happens….  I have added a screen shot of the set up.

            One thing that might be important is I have 250 fields within one main file. I have eight tables under t one file.  In Layout Mode I noticed the eight tables are comprised of different variety of the 250 fields. I think what might be effecting my ability to add a field in the Modify tab while in Browse Mode is when I am looking at the same table in Layout Mode the field I want to add isn't shown, even though it pops up when I click the "+" icon while in the Modify tab. Thus, maybe I have to somehow add or share fields with different tables… I have tried to do this and cannot figure it out...

            Any additional help would be much appreciated.

             

             

             

            • 3. Re: Unlock Field?
              philmodjunk

              There's a limit to how many pixels of data you can display in a single table view. I would guess that you have reached that limit and can not add any more columns to the view without first removing some or resizing some existing columns to make them narrower.

              I will note that List View does not have this limitation.

              • 4. Re: Unlock Field?
                NicholasPotter_1

                Yes I have encountered this issue of having too much information or fields on a table which limits adding new fields. I went in and unchecked all fields but I still cannot add new fields.  I only have a couple unlocked fields and was able to take them out (vis trash can) of the Modify tab window, but this didn't allow me to add a field  either. I have a suspicion I need to have these fields appear in the Layout view somehow. I have been working on this for hours and it is frustrating... 

                • 5. Re: Unlock Field?
                  philmodjunk

                  Try making a duplicate of your layout and clear a large number of check boxes, then see if you can add more to the view.

                  And are you adding fields all from the same table or from some (possibly) related tables?

                  • 6. Re: Unlock Field?
                    DavidSanford

                    I am having the exact same issue and am equally frustrated.  Did you ever find a way to solve this?

                     

                    • 7. Re: Unlock Field?
                      NicholasPotter_1

                      I tried the duplicate idea, but no success. I think maybe I have related tables within the same main file. This could be what has happened: I made an original file (table #1). Then I made a duplicate file (table #2). Then this occurred until I had 8 tables. Say in table #3 I made additional fields. Now tables 3-8 have the additional fields but Tables 1-2 don't. Now I can't get the info created in table 3 into table #1. I am not sure if this is the case, but maybe...

                       

                      I have attached a couple more screen shots.

                      1.) Layouts in browse mode.

                      2.) Manage-Database=Tables

                      3.) Manage-Database=Relationships

                       

                       

                       

                      • 8. Re: Unlock Field?
                        NicholasPotter_1

                        Continued 2 of 3

                        I have attached a couple more screen shots.

                        1.) Layouts in browse mode.

                        2.) Manage-Database=Tables

                        3.) Manage-Database=Relationships

                        • 9. Re: Unlock Field?
                          NicholasPotter_1

                          Continued SCreen Shot 3 of 3

                          I have attached a couple more screen shots.

                          1.) Layouts in browse mode.

                          2.) Manage-Database=Tables

                          3.) Manage-Database=Relationships

                          • 10. Re: Unlock Field?
                            philmodjunk

                            I don't see any duplicate tables nor any duplicate table occurrences in your screen shots so I don't understand what you mean by:

                            I made an original file (table #1). Then I made a duplicate file (table #2). Then this occurred until I had 8 tables. Say in table #3 I made additional fields. Now tables 3-8 have the additional fields but Tables 1-2 don't.

                            Files and Tables are not the same thing. A file can contain many tables and Manage | Database | relationships can show many occurrences of the same table.

                            Since I only see one table occurrence, you would not appear to have any relationships defined at this time.

                            That may actually be part of the problem since it looks like you are trying to set up FileMaker--a relational database system to function like a spreadsheet--which is not really what FileMaker is designed to do.

                            It is very possible that the very large number of columns of data in your table view should actually be a set of records in a related table.