4 Replies Latest reply on Apr 29, 2014 3:30 PM by Jade

    UTF8 characters only

    KelvinAitken

      Title

      UTF8 characters only

      Post

           This is a bit of a strange one.

           I have a filemaker database which tracks my images. I do all sorts of great stuff with it, creating web pages, dumping keywords and captions into existing documents, etc. One of the things I do is run an applescript to create an xml image sitemap for my website. I also have TextWrangler insert captions into basic web pages created in Photoshop.

           The problem is the apostrophe. I use a mac laptop for most of my work running OSX 10.8.5 and when I enter in an apostrophe like this: '  it enters a character which is not Unicode UTF-8 compatible. The compatible character looks similar but is different, looking like this: '

           It's more vertical in appearance. Anyhoo, what I want is to be able to bang away in Filemaker knowing that every time I use an apostrophe that it will be the correct unicode utf-8 character. 

           Is there a way I can set up Filemaker to only use Unicode UTF-8 characters? Or is this a OS system issue?

        • 1. Re: UTF8 characters only
          philmodjunk

               If you use Export Records to export the data from FileMaker, there's a drop down for selecting the character set. UTF-8 is one of the options listed in that drop down--at least I can find that option in the windows version and will assume that the mac version lists the same option.

          • 2. Re: UTF8 characters only
            KelvinAitken

                 Thanks for that. I also found, via "The Google", that I can set a field to be Unicode only in the Storage tab in the Field Options window. It would normally be set to English but if you scroll all the way down the last item is Unicode. Once set, all characters entered into the field will be Unicode compliant.

                 However, that does not change any non Unicode characters already in that field, so the Export Records tweak should fix that in the short term. Later I can do a Find and Replace on the errant characters in existing records.

            • 3. Re: UTF8 characters only
              philmodjunk

                   Or maybe just a replace field contents if you can create a workable expression to use with the calculation option.

              • 4. Re: UTF8 characters only
                Jade

                     …or replace the apostrophe characters in the Finder's System Preferences…>Keyboard>Text.  Also, try unchecking the "Use smart quotes and dashes" or choosing another option for Single Quotes.