4 Replies Latest reply on May 6, 2015 2:58 PM by jasoneatonbtc

    Web Viewer IE compatibility view problems

    MikeParsons

      Title

      Web Viewer IE compatibility view problems

      Post

           Hello,

           We currently run FMP10 and are having issues with Google maps in a Web Viewer field. When the map loads a banner at the top displays the following:

      It looks like you have enabled Internet Explorer Compatibility View. Google Maps will not work correctly unless this is turned off.

           The map does load and drop the pin in the correct position but as soon as we interact with the map the pin disappears.

           Anyone else having the same issues or know of a fix? I've tried changing the output to Google Maps classic but that creates a static map.

           Thanks

            

        • 1. Re: Web Viewer IE compatibility view problems
          philmodjunk

               Do you have Internet Explorer set to run in compatibility view?

               Is your copy of IE up to date?

               On windows, Filemaker web viewers use a "web kit" a subset of the code from IE in order to work.

          • 2. Re: Web Viewer IE compatibility view problems
            MikeParsons

                 Hi Phil, 

                 No, the compatibility list in IE is completely empty.

                 I'm running IE 11 but the issue also occurs when running IE 10.

                 I thought that might be the case, is there any way to dig in to the IE settings within the web viewer field?

                 Thanks

            • 3. Re: Web Viewer IE compatibility view problems
              philmodjunk

                   Which IE version you run makes no difference. Which version that you have installed might. I am speculating that when you install an update, that update can affect the web kit as well. There are no "settings" that you can access in this web kit.

              • 4. Re: Web Viewer IE compatibility view problems
                jasoneatonbtc

                We're having this same issue in Filemaker 11 - not sure what will happen with FM13 yet since our interface build isn't finished. Our phone agents' computers display the compatibility issue banner, even under my domain administrator profile. However, my own computer does not. I've tried comparing any settings in IE but nothing there helps. I changed compatibility settings in group and local policy but it makes no difference either. I thought it might be a difference in 32 and 64 bit OS, but the new agent machines are also 64 bit but they don't work properly. Initially, they were getting an error that said IE was out of date. Once I approved installing of IE11 on our update server it displayed a map, but on some machines I must recreate the user profile for it to show the map. If I open the map link directly in IE11, there is no problem so the issue appears to only lie within using the IE webkit within Filemaker. I've also installed every update available for Win7 and none of them had made any difference. I even disabled IE from the Windows features, but Google maps doesn't care. The next step is to restore a machine to factory defaults, install all updates, and then test the map in Filemaker. I'm not sure what I'll do if that fails.