4 Replies Latest reply on Dec 10, 2014 11:16 PM by PhuHuynh

    Webviewer does not look the same with browser.

    PhuHuynh

      Title

      Webviewer does not look the same with browser.

      Post

      Hi Everybody,

      I am new to FileMaker Pro. I am using FileMaker Pro 13v.03 on Windows Server 2012 R2. I am having a difficulty with FileMaker Webviewer.

      Currently, I am creating an OCR function by using javascript library. It works well when open on IE 11 browser but when I add it to FileMaker Webwiewer, it only show the empty page and all placeholders for input tag disappear. I thought it may cause to browser therefore borrow my friend PCs, they are using Windows 7 and event IE 10 it still works well.

      I have spent for few days for research on the Internet but I cannot find any answers. Please help.

      Best regards,

      Plato

        • 1. Re: Webviewer does not look the same with browser.
          erawson

          It could be an issue caused by mixed content (e.g. a javascript library referenced using http:// from an https:// web page) depending on what protocol your page is using and where you are loading the javascript library from.

          When you load the page using IE does it prompt you to allow blocked / potentially insecure content?

          I've found that the webviewer in Filemaker on windows will often just block mixed content and not prompt the user to allow that content. I would try adding the source of your javascript library to your trusted sites in your IE security settings. Filemaker's web viewer should respect these settings

          • 2. Re: Webviewer does not look the same with browser.
            PhuHuynh

            Hi Evan,

            Thank you for your answer. I put a local link like this to webviewer file:///C:/Users/phu.huynh/Desktop/My%20Form_Plato/ocr.html. Yes, you are right. When I run the file on IE, it prompts me to allow blocked insecure content (see attached file). I have two PCs (Windows 8.1 and Windows Server 2012 R2). I have not added/changed any settings. I don’t know why it only works on the Windows 8.1. Both of them the same IE version 11. Could you tell me how to update the IE security settings? Thank you.

            Best regards,

            Plato

            • 3. Re: Webviewer does not look the same with browser.
              erawson

              The local machine security zone settings for IE are hidden and require modifying the registry directly. Before you do that try adding a mark of the web to the top of your html file. It's basically just a way to trick IE into thinking the web page was downloaded from the internet. Here's an article about how to do that: http://msdn.microsoft.com/en-us/library/ms537628.aspx

              Hopefully that works, if not here's an article about modifying the registry values for the local machine security zone http://support.microsoft.com/kb/833633 keep in mind that you will need to decrease security instead of increase the security like the article describes, which opens up vulnerabilities that could potentially be used by malicious scripts to install viruses on your machine.

              Another alternative is to find a way to host your html file using a web server on the internet or your local network. If you do that you can easily modify the security settings for the Internet or Local intranet security zones by opening Internet Explorer, Tools -> Internet Options, Security tab

              • 4. Re: Webviewer does not look the same with browser.
                PhuHuynh

                Thank you, Evan. I will try with your solutions.