8 Replies Latest reply on Dec 20, 2014 8:31 AM by JackiefromPortland

    White space above first line of text in layout mode

    JamesRodgers

      Title

      White space above first line of text in layout mode

      Post

           I'd like to add a little white space in this text field so that the text is not against the line border.  I have seen some offer advice of adding a leading return by using a variable, but have no idea how to make that happen.  Any help is appreciated.

           Rowdy

      Screen_Shot_2012-10-01_at_5.41.00_PM.png

        • 1. Re: White space above first line of text in layout mode
          philmodjunk

               "a leading return" would be to insert a return before the first letter. Not sure you want to alter the value of your field just to space it down a few pixels.

          • 2. Re: White space above first line of text in layout mode
            JamesRodgers

                 We would like a little space at the top, such as we have made on the left - just visual preference as we enter notes in this field.

                 I'm able to get the white space by adding a return and making it a 3pt font.  I'd like to see if there is a way to automatically add this leading return, so that when you click into the field to add notes, it will fix this issue.

            • 3. Re: White space above first line of text in layout mode
              philmodjunk

                   I understand what you want. I'm just not sure that "adding a leading return" is the method to use here. Unfortunately, I can't get the "above" or "below" paragraph settings in the inspector's appearance tab to adjust the vertical position of the text when "top alighment" is specified the way that I can adjust the "left" and "right" padding. sad

              • 4. Re: White space above first line of text in layout mode
                schamblee

                     I tried to create a test and my test field looked spaced correctly. Like second screen shot.  Im using fmp 12 adv.

                      Have you tried deleting this field and recreate it and see if that fixed the issue.  This maybe related to the the theme you have selected and or the font.

                     I would make a backup of my app and maybe test different settings in test file.  I understand there is a bug in 12 when you change the theme it makes the file larger, so you make want to do testing in the backup file.

                • 5. Re: White space above first line of text in layout mode
                  philmodjunk

                       Perhaps I just don't know what I'm doing with these controls in the Inspector--there's almost no information on how to use them in Help. Note the two copies of the same text field in the screen shot. The two have identical appearance settings except for "above". For the left copy, it's zero pts. for the right, it's 3 pts. I'd expect the text in the right hand field to by 3 pixels lower in the field and it isn't.

                  • 6. Re: White space above first line of text in layout mode
                    schamblee

                         When I tested the same options as you Phil it put the line spacing above the second line.  In other words it was below the first line then above on all proceeding lines.  It not pixels either it is whole lines.

                    • 7. Re: White space above first line of text in layout mode
                      philmodjunk

                           Which is just increasing the spacing between the lines--not what is asked for here to increase the spacing between the first line and the top edge of the field.

                           OK, now figured out how the settings work--they just don't do what we would like for the request in this post. If you type in text and press return to enter a return character, then enter more text, the "above" and "below" settings increase the spacing between the the return character and the next line of text. But it does not affect the distance between the first line of text in the field and the field border.

                           What's really weird, is that I can't seem to get a difference in appearance between specifying a value in "above" and putting the same value in "below". Both produce indentical changes in appearance as fara as I can determine.

                           Ultimately, it seems simpler to not specify field borders for the field and to just draw a rectangle around the field to get borders with better vertical spacing between the text and the upper and lower borders.

                      • 8. Re: White space above first line of text in layout mode
                        JackiefromPortland

                        Here's the trigger onEntry I'm using. More of a workaround than anything, I think:

                        If(IsEmpty(COMPANIES::description); ¶ ; ¶ & ¶)

                        This will position the cursor one line down when I click in the field if it's empty. Otherwise it goes to the end of the text and enters two carriage returns.