2 Replies Latest reply on Nov 18, 2009 11:37 AM by mmccarty

    Wonky Portal/Field in IWP

    mmccarty

      Title

      Wonky Portal/Field in IWP

      Post

      Hello,

        I'm having an odd problem.  I created a portal on a layout designed for IWP.  It only has one row because I only want it to show one record. In Filemaker this portal works great, but when I go to IWP things get wonky.

      When the record is closed, the portal only shows one record.  When I open the record, I see multiple rows of data.  Well actually it is the field repeated multiple times.

      For example, when the record is closed the field is "Final Inputs provided" (like it should be). When the record is open, I get:

      "Final Inputs provided

      Final Inputs provided

      Final Inputs provided

      Final Inputs provided

      Final Inputs provided

      Final Inputs provided

      Final Inputs provided"

      All of this is now in that field.  Meaning the field that contained one line now contains twelve lines. 

      Another weird part, is I have an identical portal on the page (except is displays a different field) and it doesn't have this problem.  

       

      Does anyone have a clue as to what is happening??

        • 1. Re: Wonky Portal/Field in IWP
          TSGal

          mmccarty:

           

          Thank you for your post.

           

          "When the record is closed" - I assume you have a field that displays "closed" and another status?  Does this only display the problem when there are "closed" values?

           

          When you open the record (I assume there is a status for "open", too), where do you see the multiple rows of data?  Is this in another portal?  Is this a repeating field?

           

          If you create a new layout and add the same fields to the layout, do you get the same result? 

           

          Any other information you can provide may be helpful in narrowing down possible causes.

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: Wonky Portal/Field in IWP
            mmccarty
              

            By "open" and "closed" I mean Open Record/Request  and Commit Record/Request.

            When the Record is open aka I am editing data, the field displays correctly {Final Inputs Provided}.  When I click Commit Record/Request then the field becomes that long list like before (it is not a repeating field) {Final Inputs Provided

            Final Inputs Provided

            Final Inputs Provided

            Final Inputs Provided, etc}. 

            If I Open Record/Request, I can edit the lines as if I had originally typed all those lines.

             

            I don't know why this occurred, but I fixed it (hopefully).  I deleted the portal on my layout and then recreated it.  The portal and all the fields are exactly the same as before but this problem no longer exists.

             

            I think the computer gnomes where messing with me again :)