3 Replies Latest reply on Feb 8, 2012 1:27 PM by philmodjunk

    UPS email link question

    projay

      Title

      UPS email link question

      Post

      I created a link to track UPS package.  I basically create an email that I send to my customers that they can click on to track their package. 

      When they get the email only half of the link is clickable as shown in attached pic.

      What else is interesting is that when go to Sent Items in the email program...the whole string is clickable.

      Is their a way to make the whole thing clickable? Or is there a better way to do this...thanks everyone.

      -J

      track_link.jpg

        • 1. Re: UPS email link question
          philmodjunk

          Is this link in an email sent via FileMaker's send mail step?

          If so, I'm suprised to see any part of the link clickable as Send Mail creates plain text, not html formatted emails.

          If so, is the text shown in your screen shot the exact text specified in the send Mail script step?

          • 2. Re: UPS email link question
            projay

            Is this link in an email sent via FileMaker's send mail step?  YES  

            is the text shown in your screen shot the exact text specified in the send Mail script step?
            Send mail creates the link with variables:
            $Shiplink & $Shiptrack.

            In my email program under Sent Items...the whole link is clickable.  
            But when the customer receives it the see what you see in the screen shot. 
            Only half of it is clickable.  I guess what I could do is add a line in the email that says
            "Copy and Paste link in your browser".  Was kind of wanting to avoid that.

            -J 

            • 3. Re: UPS email link question
              philmodjunk

              Send mail creates the link with variables:

              But exactly what text is entered into the variables? The text shown, or does it include the html tags that make a link a hyperlink?

              My best guess is that you are putting the exact text shown in your screen shot into the body of the email and then the email program is attempting to convert the text into a hyperlink by supplying the missing HTML tags. The plain text is splitting in the customer's email window into two lines of text due to a need to wrap around to the next line and the client's email program is unable to handle the line break, producing the partial hyperlink shown.

              You might experiment with this format for the text in your Email body:

              <a href="put link text here in quotes">put link text here again without quotes</a>

              If that shows up as a single clickable link, you've got a solution. If it doesn't work, you may have to use the copy and paste instructions or try using an email plug in that support the use of html formatting.