2 Replies Latest reply on Apr 4, 2013 7:41 AM by jfb.fparker@

    “Button Setup” only shows “Do Nothing” when selected

    jfb.fparker@

      Title

      “Button Setup” only shows “Do Nothing” when selected

      Post

            

           I want to take a closer look at how the send email button works in the FM starter solutions “contact”. In layout mode when I right click on the button (button has a blue bar in bottom right) and select “button setup” it shows “Do Nothing” in the button setup dialogue.  When I try the button in browse mode it opens an email dialogue.  Why can’t I see the script that is associated with the button? 

        • 1. Re: “Button Setup” only shows “Do Nothing” when selected
          DillipKumarMahapatra

               Hi,

               I have just now checked the "Send By Email" button of that starter solution Contacts.fmp12 and found a script "Send Contact Record by Email attached with the button.

               If i am not wrong you might have selected the email image present just over the button. There is no such script attached with that email image. "Send By Email" button object and the email image are not grouped up. "Send By Email" button object has script attached but the email image has not. That's why when you select email image to check, so  you found “Do Nothing” in the button setup.

               It would be nice if you can share your thoughts.

               Thanks

               Dillip Kumar Mahapatra

          • 2. Re: “Button Setup” only shows “Do Nothing” when selected
            jfb.fparker@

                 You are right.  I enlarged the layout and sure enough there is an image of a envelope placed on the square which contains the button setup info.  When I right click on the square and selected button setup it showed the Send Mail script!

                 fyi; Before enlarging I tried to click and drag select which selected the square and image and it would not open.

                 Thanks for the help!