12 Replies Latest reply on Aug 27, 2014 12:10 PM by AlGin

    'Unknown Error -1' with 'Send Mail' script step

    TomPingel

      Summary

      'Unknown Error -1' with 'Send Mail' script step

      Product

      FileMaker Pro

      Version

      11 advanced

      Operating system version

      Windows 7

      Description of the issue

      Several of my users have encountered 'Unknown Error -1' failures with the 'Send Mail' script step. I was able to sit with one (they are scattered literally around the world) and observe the failure. They were using Outlook as their email client after having had problems with and changing from Thunderbird on the same computer.

      The FM solution is a runtime solution.

      Several other developers apparently have a similar issue as reported in the FileMaker forum on this web-site.

      Because several developers with different solutions have experienced this with their users, it must be a 'bug'.

      Steps to reproduce the problem

      Problem is consistent and reproducible on a machine with the problem; have not been able to cause the problem on a machine that does not have it.

      Expected result

      successful delivery of an email message to the default email client (Outlook).

      Actual result

      'Unknown Error -1'. Message not delivered to email client

      Exact text of any error message(s) that appear

      'Unknown Error -1'

      Configuration information

      Runtime Solution.

      Workaround

      NONE. Users have to use the 'hard copy' option in the solution and physically mail the information.