11 Replies Latest reply on Dec 23, 2013 11:14 AM by robyne

    ? marks in all fields - indexing issue!

    robyne

      Summary

      ? marks in all fields - indexing issue!

      Product

      FileMaker Go

      Version

      12

      Operating system version

      ipads using both OS6 & 7

      Description of the issue

      3 times in the last month, my Go users go into a record to input a timestamp and they get an error that says "record cannot be modified" then all goes blank with ? marks.

      I can't reproduce the problem on the fly.  How do I fix this permanently?  I recognize that the interim fix is to taking my system down and move the data to a clone.  But I don't want to be doing this 3 times/month. A rare instance is not so bad but this is too frequent for comfort.

      Exact text of any error message(s) that appear

      The record cannot be modified.

      Configuration information

      User will click a button that inserts the Current Time into a timestamp field.  The field is indexed.

      Workaround

      None that I know of.

        • 1. Re: ? marks in all fields - indexing issue!
          TSGal

               robyne:

               Thank you for your post.

               Was there anything about those records you tried modifying that was noticeable compared to other records that could be modified?

               Once the "?" data appears, if you quit FileMaker Go and restart, do you still see "?" in the field?  If you reboot the iPad (to reset memory), do you still see "?" in the field?  How often do users reboot the iPad?

               Does the problem only exist after an extended period of time?

               Are the other FileMaker Go users accessing a database file on a hosted server?  Or, is the database file local to each user?

               What other applications are running when the issue occurs?

               Any other information you can provide may help narrow down the possible causes.

               TSGal
               FileMaker, Inc.

          • 2. Re: ? marks in all fields - indexing issue!
            philmodjunk

                 I've seen a couple of reports over in the FM GO forum that suggest that this might happen when committing data back to a hosted database and communication is interrupted during the commit.

            • 3. Re: ? marks in all fields - indexing issue!
              robyne

                   Nothing unusual that anyone noticed.  My employee simply tapped the button, the time wheel came up, he selected the time and then tapped the screen in a clear spot.  At that point he received the message "this record can not be modified", clicked ok and that was when the record went kaput. 

                   Yes, you can still see the ? marks on this record even after restart (either via the ipad or computer).  The record is simply lost to history (fortunately, I have a back up).

                   All users access the file via a hosted server, we do not keep a local file on the ipads.

                   Other apps that were running:  Safari, Google Maps, Mail, Camera

                   Per the note above by Philmodjunk - we have experienced issues when loosing data connection (users get caught in a loop that is difficult to get out of without force your way out of Go.  I've posted on this as well).  In this case, I don't think this happened (unless it was super brief) as he as still able to access the rest of his schedule immediately afterwards.

                    

              • 4. Re: ? marks in all fields - indexing issue!
                TSGal

                     robyne:

                     Thank you for the additional information.

                     Since all users access the file via a hosted server, is it possible another person was editing the same record?

                     Since a "?" generally signifies incorrect information in a field, are you able to tap into the field and see what data may be present?

                     The applications you listed should not cause an issue.

                     TSGal
                     FileMaker, Inc.

                • 5. Re: ? marks in all fields - indexing issue!
                  robyne

                       It is possible someone was in the record (though unlikely) but not in that field.  However, when that happens the error message that comes is along the lines of  "XPerson is working with this record so you cannot modify it at this time". 

                       There is no information present in any field for that record.  You cannot delete the record either.  I've had this happen before but a long time ago and the only way to delete bad record is to take the database offline, move everything into a clone and at that point the bad record goes away.  I can do that for this but I more interested in figuring out why this is happening (at a rate I consider frequent given the elaborate fix) and what I can to do protect my system.  For instance, if this related to an indexing issue, will turning indexing for these fields help?

                  • 6. Re: ? marks in all fields - indexing issue!
                    TSGal

                         robyne:

                         Thank you for the information.

                         Yes, you should get the message that "X person is working with this record...".  However, I don't know why this is happening to you (and I know that doesn't help you), so I'm trying to get as much information possible.  I seriously doubt this would be an indexing issue, but if you want, turn on indexing and see if it makes a difference.  You can then find for "?", and this will display all the records with invalid data in that field.

                         When this issue does occur, is it after prolonged use of the file?  I'm asking to see if it is related to a possible memory conflict or corruption.

                         TSGal
                         FileMaker, Inc.

                    • 7. Re: ? marks in all fields - indexing issue!
                      robyne

                           This file has been running for about a year (I don't know if that is prolonged use or not). 

                           I tried turning indexing on and off for those fields but that did not solve anything that I can see.  Bad records still exist.

                           I am also including an image of the "error" message.  Please note, in this particular instance, the record was still ok but the user could not log out of FM Go.  He had to manually close the app and shut down and restart. 

                      • 8. Re: ? marks in all fields - indexing issue!
                        philmodjunk

                             I've had the above error message happen to me with FM Go 12. What fixed it was to reboot my phone. But I also saw other "flaky behavior" not described here so it may not be the same issue and may not respond to the same fix...

                        • 9. Re: ? marks in all fields - indexing issue!
                          TSGal

                               robyne:

                               Are you able to tap the top left icon to minimize the window?  If so, are there any other FileMaker windows open?  If so, are any of the windows related to the record in the original window?  Is all data committed?

                               Was any multi-tasking going on?  Or, did you return to this record after coming out of sleep mode?

                               Any other information you can provide of the actions taken before this issue appears may be important.

                               TSGal
                               FileMaker, Inc.

                          • 10. Re: ? marks in all fields - indexing issue!
                            robyne

                                 Hi:

                                 You are not able to tap the left icon to close out.  No other windows are open.  Data is committed after tapping of the field.  Would you suggest adding a commit data step to the script?  This does seem to happen when waking from sleep mode.

                            • 11. Re: ? marks in all fields - indexing issue!
                              robyne

                                   HI:  I just want to follow up to say that each occurrence does happen upon waking from sleep usually (but not always) when the user has left the cursor in a time field (so the field is "active").  It does not seem to matter if it's iOS6 or iOS7.  In all circumstances, the file is being accessed via cell not wifi.