3 Replies Latest reply on Dec 11, 2013 1:48 PM by TSGal

    A phantom tab setting in the paragraph

    dgbrown57

      Summary

      A phantom tab setting in the paragraph

      Product

      FileMaker Pro

      Version

      12.0v4

      Operating system version

      Mac OS 10.7.5

      Description of the issue

      I have a text field where I have set up first line indent at -80 pts, line at 80 pts, no tabs. I have confirmed this setting in browse mode. However, when I Option-tab after the first set of characters to get to the 80 point setting, it stops at what appears to be a phantom tab at 40 pts. This forces me to Option-tab twice to move over. If my first set of characters extends beyond this invisible point, then a single Option-tab moves me properly.

      The problem this creates is when I want to squeeze this information on a 3x5 card, say, then I use a smaller font and use similar settings but try to change the indentation proportionally. Sometimes on this other layout/field, the double Option-tab moves the text too far to the right (to another phantom tab beyond the line marker).

      So, how do I get rid of these phantom tab?

      Steps to reproduce the problem

      Create a text field. Font is Times New Roman size 16. Set 1st line to -80, line to 80 pts, no tabs. In browse mode, enter a recipe like "2

      Expected result

      I would expect the "doohickeys" to fall immediately under the "Granny .."

      Actual result

      See image

      Exact text of any error message(s) that appear

      No error message

      Configuration information

      I started from the Contacts starter solution to take advantage of the layouts and, most importantly, the scripts. Made changes to table name, field names, etc. Created a new layout with the same field using different fonts/sizes, etc. to display in one place the effects on other layouts. Don't think this has anything to do with the problem.

      I am using Filemaker Pro Advanced. Not sure if this is relevant.

      Workaround

      I am trying to avoid using two text fields (one for quantity, second for item) since the item name could be longer than the field in which case it will wrap to the 80 point setting. Coordination between the two fields would get out of hand.

      Tab_Problem.jpg

        • 1. Re: A phantom tab setting in the paragraph
          Benjamin Fehr

               as far as I see you've chosen the Center justification attribute, instead of Left justification. Though the word get's centered among 80pt. Tab position?!

          • 2. Re: A phantom tab setting in the paragraph
            dgbrown57

                 If you look at the inspector, you will see it is left justified. Also, if it were center justified, when I did 2 option-tabs (see bottom of graphic), the items would not be left justified at the 80 pt mark.

            • 3. Re: A phantom tab setting in the paragraph
              TSGal

                   Donald Brown:

                   Thank you for your post, and I apologize for the late reply.  Somehow, this slipped through the tracks.

                   You can set different tab stops for paragraph.  Therefore, although you may have a tab stop at 80 pts on the second line, put your cursor in the first line with Granny Smith apples and make sure the tab stop is present.  Assuming it is, set the tab stop back to 0, and then move it back to 80 points to reset it.  Does this work?

                   Any other information you can provide may be helpful in determining the cause.

                   TSGal
                   FileMaker, Inc.