5 Replies Latest reply on Oct 5, 2010 2:17 PM by TSGal

    active record is not displayed in list view

    gpupita@sestante.net

      Summary

      active record is not displayed in list view

      Product

      FileMaker Go

      Description of the issue

      you're on a record, in a form layout, when the found set is large, and a button brings you to a list view: the records that are displayed on screen do not focus on the selected record

      also: you're on a list of records, say 5000, and you're sitting on record 1000
      a button sends you to the last record but the screen does not focus on the selected record
      (an unstored calc field correctly displays that you're on record 5000 of 5000)

        • 1. Re: active record is not displayed in list view
          TSGal

          Giuseppe Pupita:

          Thank you for your post.

          I am unable to replicate this problem.  I have a large database file (8,301,440) records, and I perform a Find resulting in 828,834 records.  If I move to record 727,913 and switch from Form to List View, my record pointer is still at record 727,913.

          When you mention "a button sends you to the last recordbut the screen does not focus on the selected record", can you tell me what the button does?  How is this different than by selecting List View?

          Any additional information you can provide to help me replicate the problem would be appreciated.

          TSGal
          FileMaker, Inc.

          • 2. Re: active record is not displayed in list view
            gpupita@sestante.net

            I had tried with 50.000+ records, but I've just tried with 6.000+ and the issue is the same

            - networked file, opened via wireless connection; host is a macbook pro with FM11A; status area hidden at startup

            - I have a list view layout; in the footer I have navigation buttons to go to record first/last/prev/next, an unstored
             calc field = get(recordnumber) of get(foundcount) that tells me the current record; in the body I've an unstored calc field = get(recordnumber) to show the records being displayed

            - I click on the go to record first button; things work nicely: the first record sits at the top of the page and the current record indicator (the little black box on the left) is positioned on the first record -- ok

            - I click on the go to record LAST button; things get messed up: the field at the bottom says <record 6500 of 6500> BUT the records I see in the display are records 5500-5550 or so

            - I then go to a form layout, go to the last record, and click on a button that runs a script with the instruction

            Go to layout (a calc to go to the proper list layout)

            When I land on the list layout the field at the bottom says <record 6500 of 6500> BUT the records I see in the display are records 5500-5550 or so

            Thanks for your time

            Ciao

            G. Pupita

            • 3. Re: active record is not displayed in list view
              TSGal

              Giuseppe Pupita:

              Thank you for the additional information.  I am able to replicate the problem.  However, when I go to last record, even though the List View does not show the current record, if I then switch to Form View, the last record does appear.  When I switch back to List View, the records that displayed previously still show, and it does not include the current record.

              On an iPad, I am able to get closer to the last record than on an iPhone or iPod touch.

              I have forwarded your posts along with my findings to our Development and Software Quality Assurance (Testing) departments for review and confirmation.

              TSGal
              FileMaker, Inc.

              • 4. Re: active record is not displayed in list view
                TSGal

                Giuseppe Pupita:

                Our Testing department is aware of this issue and it has been sent on to Development for further review.

                TSGal
                FileMaker, Inc.

                • 5. Re: active record is not displayed in list view
                  TSGal

                  Giuseppe Pupita:

                  Just a quick note to let you know this was fixed in the FileMaker Go 1.1.1 update.

                  TSGal
                  FileMaker, Inc.