AnsweredAssumed Answered

Aligning objects gives fractional points to position

Question asked by scottworld on Dec 14, 2012
Latest reply on Dec 3, 2015 by TSGal

Summary

Aligning objects gives fractional points to position

Product

FileMaker Pro

Version

12

Operating system version

10.8.2

Description of the issue

When you align objects in FileMaker 12, FileMaker assigns FRACTIONAL NUMBERS (in points) to the top/left/right/down positions of the items that you have just aligned, instead of WHOLE NUMBERS. This is terrible, because FileMaker BLURS THE EDGES OF OBJECTS whose edge positions are not assigned to whole numbers. Alignment should ALWAYS result in WHOLE NUMBERS (in points). Always. Because if it doesn't, then FileMaker blurs the object.

Workaround

There is an amazing workaround to this debilitating bug that another FileMaker developer named Paul Howard discovered. These are his words, verbatim:

I don't know of a way to prevent FileMaker from aligning on a fractional point but I can tell you how to make sure that none of your layout elements STARTS OUT on a fractional point (well, at least the top and left edges) before you attempt to align them.

1. If you don't already have one, add a layout element whose top left corner is at {0,0}.
2. In the Position tab of the Inspector window, enable "Snap to Grid"
3. In Layout mode, Select All.
4. Drag your selected layout elements away from the top left corner, then back to it.

Voila! Any element that previously had a fractional position on the top or left edge is now on a whole number.

What this *won't* help with is the condition wherein you need to align one or more elements to the right edge of an element that has a fractional width value, or bottom edge of one with a fractional height value.

Outcomes