11 Replies Latest reply on Apr 12, 2013 10:23 PM by Fred(CH)

    ASCII äöü

    abonino_1

      Summary

      ASCII äöü

      Product

      FileMaker Server

      Version

      11.04 and 12.03

      Operating system version

      10.7.5

      Description of the issue

      AdminConsole.app
      - try uploading a File
      - open-dialog, foldername with german … ääääääääääää!!!!!!
      -> the foldername is unvisible !!!!!!!

      Steps to reproduce the problem

      MBP FMS11.04, 10.7.5 and Java7 (1.7.0.11)
      and
      iMac FMS12.03, 10.7.5 and Java7 (1.7.0.11)

      AdminConsole.app
      - try uploading a File
      - open-dialog, foldername with german … ääääääääääää!!!!!!
      -> the foldername is unvisible !!!!!!!
      * dear programmers - for the next 10years: please make foldernames with 'testöäüÖÄÜâéà' (de/fr/ch/au)

      Expected result

      -> the foldername is visible !!!!!!!
      (in the list)

      Actual result

      -> the foldername is unvisible !!!!!!!

      Exact text of any error message(s) that appear

      -

      Workaround

      ?

        • 1. Re: ASCII äöü

               abonino:

               Thank you for the post.

               To attempt to replicate this, I uploaded a database using the "Upload Database" action in the FileMaker Server 12 Admin Console when clicked on the "Databases" pane in the left hand side. I clicked on the main Databases folder and clicked "Created Subfolder." 

               I entered "äüÖÄÜâéàTEST" into the "Name:" field and then clicked "OK." Lastly, I uploaded my Forums.fmp12 file to that folder. The results of the upload are in the screenshot below. 

               Perhaps, I am missing a step to replicate?

               TSFalcon

               FileMaker, Inc.

          • 2. Re: ASCII äöü
            abonino_1

                 Hello!

                 i mean the folder from Finder (into the upload-dialog).
                 This Folder is a mounted Share (afp 10.7.5 Client).

                 ;-)

                 2 pict:
                 1) upload-dialog and situation from Finder (invisible)
                 2) new Folder (visible)

                 => It's the Java 1.7.11?

                 add question1: why by pick-up-dialog a button 'New Folder'? (second dialog)
                 add question2: this forum:  why i can only upload only 1 pict and not multible picts?
                 add question3: this forum: why .zip work not? (for multible picts)

                 * little detail UTFx: CH-Keyboard and DE-keyboards
                 CH: Ü = 2step-sign (¨ & U)
                 DE: Ü = 1step-sign (i have not the keyboard)

                  

                 ;-)
                 regards Arthur

                  

            • 3. Re: ASCII äöü
              abonino_1

                   2.

              • 4. Re: ASCII äöü
                Markus Schneider

                     confirmed!

                     no chance to use a folder when its name contains umlauts in the 'upload-a-database' dialog

                     To be honest, it seems NOT to be a java-problem

                     - check out other java-apps, ie 'Oxygen', an xml-environment... no problem with folders like this

                      

                     and again, can't say it enough: This forum is driving me mad, it is <beeep>...

                     edit: 'forum' means 'forum-software'

                • 5. Re: ASCII äöü
                  abonino_1

                       Markus have the same problem with connected remote to  Admin Console  (other machine) and pick-up from local folder. 

                  • 6. Re: ASCII äöü

                         abonino and markus schneider:

                         Thank you both for the replies.

                          

                         With this new information and using the steps provided, I was able to replicate this on my work station with FileMaker Server 12v3 Advanced installed on Mac OS X 10.7.5 with a local folder folder residing on my desktop. My testing indicates this issue does not occur on Windows 7.

                          

                         I forwarded your reports to Testing and Development for review. 

                          

                         TSFalcon

                         FileMaker, Inc.

                    • 7. Re: ASCII äöü
                      CamelCase_data

                           I can confirm this bug in OS X 10.8.2 too.

                           The number of different bugs related to FileMaker's poor handling of non-US characters/decimal formats/date formats is really embarrassing.

                           Maybe time to dedicate some specific resources to this?

                      • 8. Re: ASCII äöü
                        CamelCase_data

                             Speaking of language issues, I believe the proper title for this box should be "Post an answer", not "Post a Answer"...

                        • 9. Re: ASCII äöü
                          philmodjunk
                               

                                    Speaking of language issues, I believe the proper title for this box should be "Post an answer", not "Post a Answer"...

                               Sigh....

                               That's a shortcoming of the software used by FileMaker Inc. for this forum. FileMaker cannot change it. When modman, the manager responsible for this forum pointed it out to RightNow--an org now owned by Oracle, they told them that they would add his "Feature Request" to their list. surprise

                          • 10. Re: ASCII äöü
                            philmodjunk

                                 Oh yes, and a report linked to this thread has been added to the Known Bug List. This is both a database and a forum thread summarizing issues acknowledged by FileMaker Techs. It is not a product of FileMaker nor are they responsible in any way for its content--it's a community produced and supported entity.

                            • 11. Re: ASCII äöü
                              Fred(CH)

                              I noticed this problem precisely when i must updated the java to v7 machine after several problems with the Admin Console. 6 month ago.

                              Then, after updates and updates of both JAVA and FMS at this time 7v17 and 12.0.4, tht problem remains.

                              For more info, this problem was also reported later here : Folders with Swedish characters invisible to FMS Admin Console