AnsweredAssumed Answered

Authentication Error with Perform Script on Server

Question asked by user9755 on Dec 19, 2013
Latest reply on Aug 16, 2016 by DanielSmith

Summary

Authentication Error with Perform Script on Server

Product

FileMaker Pro

Version

13

Operating system version

OS X 10.8.5

Description of the issue

When I run a script using Perform Script on Server, the script does not run and an authentication error is logged. I've double checked the security settings for the account, and fmapp is enabled, and as a test I enabled all extended privileges. That account has full access to the file. I've tried running the script with full access. I can't think of anything else to try, and I cannot get it to work.

Exact text of any error message(s) that appear

"authentication failed on database "aACEv4v0_Data.fmp12" using "programmer [fmapp]"

Configuration information

This is a multi-file system. All files share the same account name and password. The script is being triggered from one file (Interface). The script that's run is in another file (Scripts). And a third file in the mix is Data. The authentication occurs with the Data file. I know the script is initiating because if I create a simplified script that simply returns what I pass in, it runs successfully.

Outcomes