1 Reply Latest reply on Feb 20, 2012 2:29 PM by philmodjunk

    Auto enter on import

    JeanAnneMayhall

      Summary

      Auto enter on import

      Product

      FileMaker Pro

      Version

      11

      Operating system version

      Windows 7

      Description of the issue

      I use the file name of an excel spreadsheet as the auto enter DATA description for records I am importing from an Excel file into Filemaker Pro.   All is well. However, when I later create a NEW record, the same auto enter DATA (in this case the file name of the Excel file) still populates the field...even though I am NOT importing.  It confuses the accuracy of our Find for that particular excel filename because any new records entered also carry the same 'data'. 
      What am I doing wrong? 
      The only way I can see to stop that 'data' from auto entering with each new record is to erase it from the data desciption box in the auto enter menu?  That can't be right?
      Jean Anne

        • 1. Re: Auto enter on import
          philmodjunk

          It's how this features was designed to work and it is working as it was designed.

          auto-enter settings are primarily intended for entering data when a new record is created. You have the option to permit auto-enter operations when you import data if you enable the option for doing so when setting up the import.

          Auto-enter should not be used to enter data that is only to be entered during import and not regular data entry. To add data to imported data without using auto-enter you can use Replace Field Contents immediately after the import to enter the data.

          You can also import data into a global field with an auto-enter calculation that enters the desired data into the field. With this approach, you can disable the auto-enter for manual data entry by clearing this global field. (Learned that trick from LaRetta.)