2 Replies Latest reply on Apr 15, 2014 9:28 PM by scottworld

    BUG REPORT: FileMaker 12.0v5 thinks I am trying to share a file

    scottworld

      Summary

      BUG REPORT: FileMaker 12.0v5 thinks I am trying to share a file

      Product

      FileMaker Pro

      Version

      12.0v5

      Operating system version

      OS X 10.8.5

      Description of the issue

      There is a brand new bug in FileMaker 12.0v5, where FileMaker THINKS that I am trying to share all of my local files EVEN THOUGH I AM NOT trying to share them.

      This bug does NOT happen with FileMaker 13.

      Every single time I open up a LOCAL FILEMAKER DATABASE that lives locally on my own laptop's hard drive (OS X 10.8.5), FileMaker 12.0v5 gives me this error message:

      "FileMaker cannot share files because another user is already sharing files using FileMaker Pro on this computer."

      This happens every single time I open up a local file. Yet I'm not trying to share any files, and FileMaker Network Sharing is ALREADY TURNED OFF in my FileMaker Networking Settings. There are no other instances of FileMaker Pro running, and FileMaker Server has never been installed on this laptop. I have also tried quitting out of FileMaker and restarting my laptop. All to no avail.

      Yet, opening the file with FileMaker 13 DOES NOT yield the same error message.

      So this is a bug in 12.0v5, which is driving me absolutely batty!!

      You can see in the attached screenshot that FileMaker Network sharing is ALREADY TURNED OFF, yet FileMaker 12.0v5 keeps prompting me that it can't share any of my files! No matter which local file I open, I keep getting this error message. There are NO OTHER FILEMAKER PROCESSES RUNNING ON THE COMPUTER.

      Screen_Shot_2014-04-15_at_8.47.18_PM.png

        • 1. Re: BUG REPORT: FileMaker 12.0v5 thinks I am trying to share a file
          steveromig

               Scotty321 -

               Thank you for your message.

               This is not a bug in FileMaker 12 per se.  There are a number of things that can cause this.  Consult the following knowledge base articles to see if any of them apply:

          http://help.filemaker.com/app/answers/detail/a_id/6899/

          http://help.filemaker.com/app/answers/detail/a_id/6098/

               Typically one, or more of the items discussed in these articles will fix this issue.

               TS_SHARK
               FileMaker, Inc.

          • 2. Re: BUG REPORT: FileMaker 12.0v5 thinks I am trying to share a file
            scottworld

                 A-ha, thanks so much!! :) The first link that you gave me solved the problem for me!! The "fmiwp" extended privilege was assigned to my user account in all of my files, even though I don't use fmiwp. So I disabled that Extended privilege in all of my files, and that seems to have fixed the problem!! :)  Thank you!! And that explains why the problem wasn't happening in FileMaker 13 -- because there is no Instant Web Publishing in FileMaker 13!

                 You know, I had actually seen that Knowledge Base article earlier today, but I totally ignored it because it said that it was for FileMaker 9 only. Perhaps that article could be updated to list all versions of FileMaker, including FileMaker 12 and 13?

                 However, here's something equally unusual… I have absolutely ZERO FileMaker processes running on the computer right now. No instances of FileMaker Pro nor FileMaker Server are running, and Activity Monitor shows that no FileMaker processes are running. BUT… take a look at the attached screenshot. When I go into Network Utility and run a localhost port scan for port 5003, it shows that port 5003 is open on my machine. Is this normal? I'm not super-concerned about this because I'm no longer getting that error message within FileMaker Pro, but I just wanted to make sure that this is normal for this port to be open on my computer without FileMaker even running at all. Please see attached screenshot.

                 In any case, thank you so much for solving my problem!! :) Yay!!!!!!! :)