2 Replies Latest reply on Nov 12, 2009 7:47 AM by MartinBrändle

    Bug/Warning: FMS Admin Console goes deaf after Mac OS X Security Update 2009-006

    MartinBrändle

      Summary

      Bug/Warning: FMS Admin Console goes deaf after Mac OS X Security Update 2009-006

      Description of the issue

      FileMaker Product(s) involvedFileMaker Server Advanced 10.0.2.206  Operating System(s) involvedMac OS X Server 10.5.8 (Build 9L30) Hardware and Server Setup Xserve 2.8 GHz Quad-Core Intel Xeon Database and CWP/Webserver, two-machine setup   Detailed description of the issueAfter having updated Mac OS X 10.5.8 Server two days ago with the most recent Security Update 2009-006, the FMSA Admin Console goes deaf: Start Database Server button is green, but CWP is running. No clients and databases displayed. No reaction upon clicking the Start Database Server button. The fmsadmin terminal command shows that databases are open, clients are connected. Backup schedules are running. The confirmation e-mail of the last nightly backup schedule was not sent, but the schedule finished fine. Port scan of ports 16000-16020 showed that all required ports (16000, und 16001 and 16004 for DB server) were open. Exact steps to reproduce the issueWe use the following procedure for updating the OS through these Terminal commands: fmsadmin closefmsadmin stopsudo softwareupdate -i -areboot  FMSA is configured to startup automatically the database and the CWP server.  Expected resultStandard FMSA Admin Console view displaying number of databases and clients in box server information. Actual Result FMSA Admin Console displays- green Start Database Server Button, although DB server is running (indicated by Terminal commands fmsadmin list databases and fmsadmin list clients, and clients being connected to server).  - running Web Publishing Engine, displayed by greyed out Start Web Publishing Button, and indicated by functioning website accesses and searches.- empty information for hosted files, FM Pro clients, and session in server information box.  Clicking Start Database Server Button results in no action.Clicking on any of the FMSA Admin Console actions results in message to start database server first. Exact text of any error message(s) that appearedNoneAny additional configuration information/troubleshooting that is relevant to the issueA similar configuration on a Xserve 2x2.0 GHz PowerPC G5 runs fine. This server is set up as database/CWP server, single-server setup. Database and CWP server were, however, not set to start automatically.Any workarounds that you have foundServer was rebooted next night and everything worked as expected. System log files and FMSA log files can be obtained on request.