AnsweredAssumed Answered

BUG: Can't control field padding in FM12

Question asked by scott2si on Jun 26, 2012
Latest reply on Jun 27, 2012 by james_quiggins

Summary

BUG: Can't control field padding in FM12

Product

FileMaker Pro

Version

12

Operating system version

10.7.4

Description of the issue

When you create a new layout using a theme in FM12, you'll notice that each field suddenly has PADDING on the left side of the field. (In other words, the text that you type is not flush left against the left edge of the field.)

Okay, that's fine... BUT YOU CAN'T CONTROL THE PADDING!! What if you want to REMOVE the padding? What if you want to INCREASE the padding?! You can't do it. You USED TO BE ABLE TO CONTROL PADDING VIA THE INSPECTOR, ON THE "APPEARANCE" TAB, UNDERNEATH INDENTS, LEFT INDENT. But that NO LONGER DOES ANYTHING IN FM12.

You ONLY OPTION is to go to the Appearance tab of the Inspector and click on the far right button in the section Style Defaults (i.e. the white box with a red diagonal line). That will remove the padding and make it human-accessible again, YET THAT ALSO REMOVES EVERY SINGLE BIT OF THE THEME ALTOGETHER.

So if you want the theme but without padding, you then have to manually & painstakingly recreate the theme on your own, JUST TO REMOVE THE PADDING.

RIDICULOUS. Is there no shame at all amongst the engineers at FMI? How could they release this crap upon the world?

Outcomes