3 Replies Latest reply on Apr 18, 2013 2:13 PM by philmodjunk

    Button hover causes merge variable to revert to prior value

    LaRetta_1

      Summary

      Button hover causes merge variable to revert to prior value

      Product

      FileMaker Pro

      Version

      12.0v3

      Operating system version

      Windows XP

      Description of the issue

      If using a merge variable with a button attached, hovering the button reverts the merge variable to its prior value.

      This is, at the least, an unexpected behavior and would really be considered a bug since ALL objects on the layout should refresh consistently.

      Steps to reproduce the problem

      A sample file demonstrating the issue (and the on-going discussion) can be found in the opening post in the link below:

      http://fmforums.com/forum/topic/88038-hover-triggers-merge-variable-update-by-itself/

      Expected result

      When merge variable updates, it should remain as the new value.

      Actual result

      Merge variables revert to prior value when hovered.

      Exact text of any error message(s) that appear

      none

      Configuration information

      Several have tested this process and it appears to produce same incorrect results for Mac as well.

      Workaround

      Workarounds aren't the answer since this indicates a broader refresh issue in the layout layers.

        • 1. Re: Button hover causes merge variable to revert to prior value

               LaRetta:

               Thank you for the post.

                

               The sample file provided is excellent and was submitted to Testing and Development as is. I can confirm this occurs both on Windows and Mac OS X.

                

               One additional question to clarify: were any of the layout objects in the sample file copied from a converted file or another FileMaker Pro file? 

                

               TSFalcon

               FileMaker, Inc.

                

          420

          • 2. Re: Button hover causes merge variable to revert to prior value
            LaRetta_1

                 Hi TSFalcon,

                 I originally identified the issue while implementing in a Client's file (based upon Ocean) so I created a brand new file using Ocean with all new objects and it produced same behavior.  I then created second file based upon Cool Gray (the one attached in the link) again with all new objects but I DID copy the two top-right buttons over from the newly created Ocean file. 

                 I replicated the complexity exactly to the client file in case the issue was not with hover but rather with ExecuteSQL() or my implementation of the less-than-normal technique.  The results remained consistent in all three files (all three created in 12.0v3 using FMPA on Windows XP SP3).  I haven't tested the remaining themes, assuming that the button hover, layout layers and refresh would behave the same for all themes.

                 Thank you so much for your attention.  smiley

            • 3. Re: Button hover causes merge variable to revert to prior value
              philmodjunk

                   This issue has been added to the Known Bug List. Please post any comments about that entry here to keep the list "clean". A copy of the sample file was also added to the database entry for this bug report.