4 Replies Latest reply on Jun 24, 2015 11:16 AM by DonaldMerand

    Can't Edit Backup Schedules

    DonaldMerand

      Summary

      Can't Edit Backup Schedules

      Product

      FileMaker Server

      Version

      14

      Operating system version

      OS X 10.9.5

      Description of the issue

      When I go to edit a backup schedule in the FMS admin interface, it won't let me get past step 2: "Backup Options". I'm clicking "next" over and over, changing everything I can, restoring defaults, and nothing seems to make it go forward.

      It doesn't move past step 2 for existing schedules, or for new schedules.

      Steps to reproduce the problem

      - Open FMS Admin http://server_address:16001
      - Click "Schedules"
      - Click the grid icon in the upper-right which hides all of the schedule functions, and then click "Create A Schedule"
      - Do whatever you want in step 1.
      - Try to click through step 2. It won't do it!

      Expected result

      The expected result would be that I could edit schedules, you know, through all of the steps, and then be done editing schedules.

      Actual result

      I get stuck in step two any time I try to edit or create a schedule. This is actually a big problem for us since our backup schedule is backing up to the wrong hard drive, and I can't fix it, or make a replacement schedule that fixes it.

      Exact text of any error message(s) that appear

      No error messages.

      Configuration information

      We have a very standard one-machine FMS configuration. Webdirect is enabled, also ODBC. Not PHP or XML. We have about 40 simultaneous users at peak.

      We have our databases being served from a solid state drive which is distinct from the OS. And we are trying to do backups onto a third drive, though they are currently getting put onto the main OS drive.

      Workaround

      We are currently manually moving backup files daily from the wrong hard drive location to the proper hard drive location. It is tedious and time-consuming.

      Screen_Shot_2015-05-28_at_09.12.23.png

        • 1. Re: Can't Edit Backup Schedules
          TSGal

          Donald Merand:

          Thank you for your post.

          Once you enter the Backup Folder, did you validate the Backup Folder path?

          TSGal
          FileMaker, Inc.

          • 2. Re: Can't Edit Backup Schedules
            DonaldMerand

            Hi TSGal,

            Yes, I definitely validated the backup path. I also tried resetting the path back to the "default" – neither option will allow me to move forward. As I stated in my original post, there is literally nothing that I can do to convince FMS to let me beyond that step of the "schedules" wizard.

            I wonder if there's a way to set up a schedule outside of the wizard? Can I possibly script schedule setup from the command line? That would be very nice. But the fmsadmin app for the CLI seems to have no such flags.

            • 3. Re: Can't Edit Backup Schedules
              TSGal

              Donald Merand:

              If the backup path has been validated by FileMaker Server, and you still cannot proceed, then something else is causing FileMaker Server to not proceed.  Since I am unable to replicate the issue, I would close FileMaker Server, move the database files out of the Databases folder and onto the Desktop, remove FileMaker Server entirely from your hard drive, reinstall FileMaker Server, and place the database files back in the Databases folder.  Launch a browser on the server, access Admin Console, and make sure everything is running again.  Then, set up a new Backup schedule.

              Keep me updated with any progress.

              TSGal
              FileMaker, Inc.

              • 4. Re: Can't Edit Backup Schedules
                DonaldMerand

                Hi,

                I updated to Server version 14.2 (which I had to do to fix a licensing issue), and it appears to have solved the scheduling issue, so that's good!

                It happened none too soon, our backups had filled up the OS hard drive on our FMServer :(