7 Replies Latest reply on Feb 4, 2015 5:20 AM by fcgmelinda

    Can't open files

    AlanGettner

      Summary

      Can't open files

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      OS X

      Description of the issue

      When we try to open files, get "Permission Denied".  Not asked for a password.  Just get this message. How can I get it to open files?

      Steps to reproduce the problem

      Tell me.  Tried everything system allows

      Expected result

      Ability to open files

      Actual result

      None

      Exact text of any error message(s) that appear

      "permission denied"

      Workaround

      None

        • 1. Re: Can't open files
          RickWhitelaw

          I've never seen this happen. Is the dialog that pops up coming from FMP or OS X? Have you tried repairing permissions? Have you altered the permissions for the files?

          • 2. Re: Can't open files
            Markus Schneider

            Seems to be an OSX message.. What permission are set (finder get info of that FileMaker file)?

            • 3. Re: Can't open files
              fcgmelinda

               

              This is happening to me as well. Running OSX Mavericks - 10.9.5  Upgraded FM Pro earlier today from 13.0v4 --> 13.0v5. Opened one of my DB files, entered data, left it open while I went to lunch, came back, FM Pro had crashed, tried to re-open file I had been working in, got the permission denied message (see below).

              I tried rebuilding my permissions - no luck; but I believe that is because the FM Pro app lives on my computer, while the actual DB files are on our Apple server.  I don't know why the permissions would have changed on the DB files on the server. I can open a set I keep on my machine that I test with.

              I think the problem may be with something in the upgrade, even tho' it's appearing like it's something with OSX.

              Any help is appreciated.

              Here is a screen print of the error message:

               

              • 4. Re: Can't open files
                TSGal

                Melinda Belleville:

                Thank you for your post.

                Hold down the option key as you open the database file.  This will bring up a dialog box to enter the Account Name and Password.  Enter a [Full Access] account name and password and see if the issue occurs.

                If the issue still occurs, close the file on the server and copy it to your machine.  Are you able to access the file locally?

                If this also fails, run Recover (from the File menu) on the database file, and when it completes, open the recovered file.

                Keep me updated with any progress.

                TSGal
                FileMaker, Inc.

                • 5. Re: Can't open files
                  fcgmelinda

                  Thanks for your help, TSGal. I could not get a dialog box to pop up when opening the DB file.  This may be because our files on the server are not restricted by an account name/password. If your are connected to the server you have access to everything on the server. We are a small company and have no need to segregate most things. Anything that shouldn't be seen by employees is kept on one of the two principals laptops. 

                  I also tried to copy one of the DB files to my machine and it tells me I do not have permission to access the file.

                  I tried to recover one of the files and it will not recover because it says it is in use.  

                  My theory is that I left the main DB file open when I went to lunch. The server may have tried to do an incremental backup during this time, it detected the file had been changed and attempted to back it up, but because the file was open, it couldn't back it up or it did and set the file to the wrong permissions... something happened on the server to lock me out.

                  I'm waiting for the guy that deals with the server to come in (of course, he's running late this am) and we will look at it together on that end. 

                  I will advise when/if we get it working again.

                  Thanks for your advice.

                  • 6. Re: Can't open files
                    philmodjunk

                    I would never, ever host a database file for Filemaker Clients to access without password protection of some kind. If your regular users can open the file with a [Full Access] privilege set, they can make design changes to the hosted file and this can be very easy to do even by accident. Note that Shift-L for entering a word with a capital L is very close to Ctrl or command L--the keyboard shortcut for entering layout mode. This could lead to a user trying to enter "Last" but putting "ast" as layout text directly on your layout.

                    And this is just one example of a possible accident.

                    • 7. Re: Can't open files
                      fcgmelinda

                      PhilModJunk - I appreciate your concern, but as I said, we are a small office and I have the app that opens FM files on my computer, not on the server. Only the files are on the server and the info we keep there is not anything that anyone else in the office would have any reason to even try to open.  If we kept a large amount of data necessary for a critical part of our business in FM, I can assure you I would have recommended a long time ago we protect it more vigorously. Most of our guys are not highly computer-literate, either. They have a hard time, sometimes, just finding their own stuff on the server - much less the DB files.