9 Replies Latest reply on Feb 27, 2012 12:50 PM by philmodjunk

    Can't opened saved databases

    MicheleHogan

      Summary

      Can't opened saved databases

      Product

      FileMaker Pro

      Version

      11

      Operating system version

      Mac OSX 10.6.8

      Description of the issue

      When I try to open a saved database that was working fine the day before I get the error message The file "name of file"could not be opened (Not Found)

      Steps to reproduce the problem

      I created a new database closed the program and tried to open the new database and received the same error message.  I have tried to repair permissions to no avail.

      Exact text of any error message(s) that appear

      The file "Name of File" could not be opened (Not Found)

      Screen_shot_2012-02-22_at_3.33.41_PM.png

        • 1. Re: Can't opened saved databases
          philmodjunk

          Open Manage | External Datasources and see what you have for external data sources.

          This error message appears when an external datasource reference fails to find the referenced file. Saving a copy of a file produces a copy in a new location and/or with a new file name and this could keep such a reference from working and then you get the above message.

          And if the file you are opening is named "Hardware Inventory", be advised that yes, it is possible to create an external datasource reference between a file and itself.

          • 2. Re: Can't opened saved databases
            MicheleHogan

            There is nothing listed for external data sources

            • 3. Re: Can't opened saved databases
              philmodjunk

              Hmmm,

              When I try to open a saved database....

              Exactly how are you trying to open it? Double clicking the file? Launching FileMaker and using Open from the file menu? Or ??

              The error message you show normally does not prevent a file from opening. You get that error message and a dialog opens where you can either find and select the file to open or click cancel. Once you have dismissed the dialog, the file should be open. The exception to that is when something you do from within an open FileMaker file results in a reference to the file and FileMaker attempts to open the file so I am trying to get a clearer view of the exact steps you took before being stymied by this error message.

              • 4. Re: Can't opened saved databases
                MicheleHogan

                I have tried every way I can think of.  I normally just clicked on recent in the screen shown in the attached screen shot.  I have also tried to open by going through File / Open to no avail.  It was working fine on Tuesday.  Wednesday I went to open the Printers.fp7 file and got the error message and then tried the Teachers / Hardware Inventory files and got the same message.  I tried to create a new database (its the one called datatest) I was able to create it but now I get the same error message on that file as well.

                • 5. Re: Can't opened saved databases
                  philmodjunk

                  Did you save these copies by choosing "save a copy as..."?

                  Are you attempting to open the copy thus saved or the original?

                  Any attempt to open the files from recent items will fail if the selected file has had its name change or if it has been moved.

                  Can you find the file without launching filemaker. (Open folders until you can see the icon for the database file.)?

                  If so, can you double click that file icon and get the file to open?

                  • 6. Re: Can't opened saved databases
                    MicheleHogan

                    i was trying to open the original files.  I have not changed the names or moved the files.  I have searched using both .fp7 and the file names to locate these files.  Its like they don't exist.  I don't undertand how I could open them and work with them on Tuesday and have them not open or worse yet not be found on Wednesdsay.  If is also strange that I could create a new database on Thursday afternoon and an hour later not be able to open it and get the same error message.

                    • 7. Re: Can't opened saved databases
                      philmodjunk

                      Where on your computer were the originals located? To where and to what file names did you save the copies?

                      • 8. Re: Can't opened saved databases
                        MicheleHogan

                        I can only assume they were saved in my documents folder.  If I need to use the database I would click on the FileMaker icon on my desktop at which point the FileMaker QuickStart window would open.  From the Open a Database box I would choose the database I needed from Recent Files.  It would open, I would enter whatever data I need to.  I would then go up to FileMakerPro and down to quit FileMakerPro.  I never saved or made a copy of any of the databases.

                        • 9. Re: Can't opened saved databases
                          philmodjunk

                          That's not a safe assumption to make.

                          When you select New Database, a dialog opens where you specify the name of the new file and the location where you will have it saved. One of the reasons I'm having trouble imagining a scenario to fit your issue report is that you can't get past that step without creating a new database file somewhere on a hard drive connected to your computer. The only place where the file would disappear automatically would be if you specified the temporary items folder--can't see how that would happen, but it fits your description of creating a brand new file and then being unable to open if from recent items.

                          Another possibility would be to save the file to your desktop and then log in under a different user account. Since each user has a different folder for desktop items, a file from recent items would fail to find and open the file in that case as well.

                          I suggest that you use an operating system based file search utility (select Search from the start menu for Windows systems.) and search for your file by name to see if it can be found anywhere on one of your hard drives.