10 Replies Latest reply on Aug 27, 2012 9:44 AM by BrentHedden

    Can't use the <> operators in a portal filter calculation FMP12

    BrentHedden

      Summary

      Can't use the <> operators in a portal filter calculation FMP12

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      Windows 7 - 32 & 64bit

      Description of the issue

      With the filter portal records option, I use the following calculation that works as expected (shows all records with non-blank Field contents)
                ChildTable::Field ≠ ""

      But however when I use the following simular calc, it won't display any records in the portal (but it should, as all of the Field contents are not blank!)
                ChildTable::Field <> ""


      I've always been able to the greater than/less than symbols to indicate 'not equal to' and it's documented behavior in the 'Comparison operators' section of the manual.  If I use this same test just using the calculation engine (using the data viewer), then it works as expected using either operator.  So it appears that it's only applicable to the portal filtering feature.

      Steps to reproduce the problem

      This problem holds true whether it's a brand new file created with v12 or converted from v11. It also doesn't matter if the relationship used in the portal is sorted or not.

      Should be able to reproduce on any layout portal.  The Filter Record option has to use the greater than/less than operators, like such -
            ChildTable::Field <> ""

      Expected result

      In the following calculation -
           ChildTable::Field <> ""
      Supposing the referenced field(s) have some kind of content in them, then I should see all of the related records in the portal.

      Actual result

      I see no records in the portal.

      Exact text of any error message(s) that appear

      N/A

      I see a blank portal.

      Configuration information

      This problem appears to only happen with portal filter.  Any other calculation that uses these operators works as expected.

      Workaround

      Instead of using the <> operators, I can use the ≠ operator instead. 

      Works fine in FileMaker Pro 11.03